RV.Net Open Roads Forum: Folding Trailers: Suburban DD-17dsi heater

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Folding Trailers

Open Roads Forum  >  Folding Trailers

 > Suburban DD-17dsi heater

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev  |  Next
Sponsored By:
plschrader

kern County

New Member

Joined: 05/24/2010

View Profile


Offline
Posted: 10/12/11 08:41pm Link  |  Print  |  Notify Moderator

Hmmmmm............I will think about that and go watch television

opnspaces

San Diego Ca

Senior Member

Joined: 12/22/2004

View Profile


Online
Posted: 10/12/11 10:46pm Link  |  Print  |  Notify Moderator

You might be able to save the $13. If you don't already have the new regulator try turning the bottle off and then disconnect the hose. Actually it looks like you already did that part.

Remove the tank and see if it actually feels full. The tank gauges only tell you if there is pressure in the tank. The problem is there is always pressure until you run out of LP and then suddenly there is no pressure.

If you can feel the propame sloshing around in the tank hook it back up to the regulator and turn it on very slowly. Now use the stove to bleed the line of any air. Then see if the heater works.

If no heat then you could try the regulator.


1996 Suburban 4x4. 350, 4.10 3/4 ton
2005 Jayco Jay Flight 27BH
1986 Coleman Columbia Popup.

the techwriter

Utah

Full Member

Joined: 08/20/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 10/13/11 12:01pm Link  |  Print  |  Notify Moderator

Remove the guage from the tank. It is not necessary and is prone to causing the failure you describe.


2010 Viking 2465 SST PUP
2000 Ford Explorer w/WDH
Me, DW, and Harvey the wonder dog!


plschrader

kern County

New Member

Joined: 05/24/2010

View Profile


Offline
Posted: 10/13/11 01:19pm Link  |  Print  |  Notify Moderator

I took off the tank and shook it and I hear sloshing. I hooked it back up and now there isn't even gas coming out at the stove. The gauge is on but I will go out and take it off.

plschrader

kern County

New Member

Joined: 05/24/2010

View Profile


Offline
Posted: 10/13/11 01:24pm Link  |  Print  |  Notify Moderator

oops. Didn't have the gas open at the stove. Duh

AplusMM

St Louis Metro

Full Member

Joined: 08/29/2010

View Profile



Posted: 10/13/11 11:18am Link  |  Print  |  Notify Moderator

plschrader wrote:

One more thing since I first posted. After the fan comes on, the igniter, I assume, clicks repeatedly, stops, clicks repeatedly again and I think does it a third time before it gives up.


The clicking sound you are hearing is the igniter trying to light the burner. If it is trying to light the burner the sail switch is operating correctly.

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 10/13/11 01:55pm Link  |  Print  |  Notify Moderator

Did you replace the regulator?
Do you have another LP bottle maybe off barbeque?


Bud
USAF Retired
Suzuki XL7 pushing Pace Arrow



plschrader

kern County

New Member

Joined: 05/24/2010

View Profile


Offline
Posted: 10/13/11 01:57pm Link  |  Print  |  Notify Moderator

I haven't gone to get the regulator yet. I will put the bar-b-q bottle on it.

plschrader

kern County

New Member

Joined: 05/24/2010

View Profile


Offline
Posted: 10/13/11 02:07pm Link  |  Print  |  Notify Moderator

Nope. That bottle seems to have less gas in it but I tried it anyway. I didn't take the regulator off the barbeque. The regulator on the tent trailer has two round body housings and the one on the barbeque has only one.

plschrader

kern County

New Member

Joined: 05/24/2010

View Profile


Offline
Posted: 10/13/11 01:27pm Link  |  Print  |  Notify Moderator

No luck. The gauge is off. The tank sloshes. I turned on the gas real slow. The igniter still makes three tries to start then gives up.

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev  |  Next

Open Roads Forum  >  Folding Trailers

 > Suburban DD-17dsi heater
Search:   Advanced Search

Search only in Folding Trailers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS