RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'gregory.crotto' found 1 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
Trouble with new AC

I have a technical question, we have a 2011 Newmar Mountain Aire with 3 AC units, since June 10, 2014 we have had to replace the front unit 3 times for different reasons but there is one constant on the last two Dometic AC units. During the day the unit runs perfectly, however once it cools down outside and the sun goes down the unit fan comes on and runs 30 - 40 seconds and shuts off. The compressor never comes on and this happens every few minutes. The mfg hasn't been able to offer any explanation. I know I'm not crazy because a friend has replaced his unit twice in the past year and his does exactly the same thing. Any advice or solution would be greatly appreciated as I can't imagine that it's good for the unit to cycle that often.
gregory.crotto 07/21/15 06:45pm Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2015 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS