RV.Net Open Roads Forum: Fifth-Wheels: Challenger Black Tank Flush

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Fifth-Wheels

Open Roads Forum  >  Fifth-Wheels

 > Challenger Black Tank Flush

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
KY5B

Wise County TX

New Member

Joined: 05/29/2007

View Profile


Offline
Posted: 05/29/07 04:00pm Link  |  Print  |  Notify Moderator

Just purchased a Challenger from Keystone. 29rkp. It has a Black tank Flush hose connection. It doesn't work...i.e No water gets to the balck tank. Keystone told me it was possibly a check valve problem. However there is no check(backflo) valve at the hose connector. Keystone customer service could not help me. Has anyone else had this problem? Rig was purchased and manufactured in Feb 2007. Yes, I have the black tank valve open...(smile) Thanks

dbbls

Missouri

Senior Member

Joined: 09/29/2005

View Profile



Good Sam RV Club Member


Posted: 05/29/07 04:18pm Link  |  Print  |  Notify Moderator

If it was manufactured in Feb 2007, the problem is Keystones. Take it back to the dealer.


2011 F-350 CC Lariat 4X4 Dually Diesel
2012 Big Country 3450TS 5th Wheel

jjfay03

Washington State

Senior Member

Joined: 04/06/2007

View Profile


Offline
Posted: 05/29/07 11:10pm Link  |  Print  |  Notify Moderator

Hello, I just bought a Challenger 34 BHS this weekend please let me know what the problem was and if Keystone was helpful fixin your problem.

THanks,

John


John and Jeannine + 3 Boys 12, 9, and 7.
2007 Dodge 2500, 5.9 CTD LB, Husky Brake Controller,
Linex, Firestone Airbags, and a Pac Brake.
2010 Keystone Cougar 29' BHSWE
1 Basset Hound named Maddie and her boy friend Little Boy!!

Humpty

Clayton, NC

Senior Member

Joined: 04/20/2006

View Profile



Good Sam RV Club Member

Offline
Posted: 05/30/07 08:08am Link  |  Print  |  Notify Moderator

We just got an 07 33DBB with 2 black tanks. One Flush works, the other does not. I have not had a chance to trouble shoot yet. When I have a chance, I will remove the panel by the 'water works' station to look for an anti-siphon valve. I bet there is one installed backwards somewhere.


If I can't figure it out, I will let the dealer take care of it at the end of the season.


2007 Challenger 33DBB w/ Sidewinder
2009 GMC 3500 CC DRW
B&W Companion Hitch

TnTtravelers

East Slope Sierra, California, USA

Senior Member

Joined: 08/15/2004

View Profile


Offline
Posted: 05/30/07 08:47am Link  |  Print  |  Notify Moderator

Check to see if the black and grey dump valves are marked backwards. And please let us know what you find. I suspect that this may help others with similar models...


Tim and Tina (kudo too)
Livin' good, while the livin's good!

2005 Ford F350, 4x4, Crew Cab, Short box
2007 Everest 295TS 5th Wheel, Superglide hitch
JT Stabilizers
Firestone Air Suspension System
TST tire pressure mntr system

exakpix

Oklahoma

Full Member

Joined: 10/19/2005

View Profile



Posted: 05/30/07 09:40am Link  |  Print  |  Notify Moderator

My Everest had an anti-siphon/pressure release valve that started leaking; after I tried to clean it then it plugged completely. Found it behind the shower faucet. Keystone was not much help so I just put in a brass staright line check valve and it works just fine. Here's the original: http://groups.msn.com/WarrenandLynda/ala........a2006.msnw?action=ShowPhoto&PhotoID=1705


'05 Keystone Everest 323P
'01 F350 Crew Cab 4x4 V10

Goin4forty

Wisconsin

Senior Member

Joined: 03/11/2006

View Profile


Offline
Posted: 05/30/07 09:42am Link  |  Print  |  Notify Moderator

KY5B wrote:

Just purchased a Challenger from Keystone. 29rkp. It has a Black tank Flush hose connection. It doesn't work...i.e No water gets to the balck tank. Keystone told me it was possibly a check valve problem. However there is no check(backflo) valve at the hose connector. Keystone customer service could not help me. Has anyone else had this problem? Rig was purchased and manufactured in Feb 2007. Yes, I have the black tank valve open...(smile) Thanks


Mine has always worked fine however our friends was installed backwards. If they are not taking the time to look at the part it is a 50-50 shot I guess. We took off the panel ,and turned it around and now it works fine. I agree that this is a dealer issue and should be easily fixed by them.

Even if you have the black tank valve closed, water will still flow through the flusher, that is if the backflow preventor is installed correctly. It will just fill up your tank in time and that can create a mess.


2007 34RBH Keystone Challenger
2005 Chev 2500HD CC, D/A, 4X4, Hypertec, Prodigy, Mor-Ryde, Firestone Airbags, JT Strong Arm
2007 Polaris Ranger SE XP700


KY5B

Wise County TX

New Member

Joined: 05/29/2007

View Profile


Offline
Posted: 05/30/07 01:16pm Link  |  Print  |  Notify Moderator

Thanks for the feedback folks. EXAKPIX, how did you get to the valve behind the shower? I think you have my problem identified. The hose from the Flush connection goes up to the rear of the shower!! The picture you sent goes well with the information from Goin4forty. Thanks again.

KY5B

Wise County TX

New Member

Joined: 05/29/2007

View Profile


Offline
Posted: 05/30/07 01:23pm Link  |  Print  |  Notify Moderator

Further information for others who replied. The valves are marked correctly. I removed the wall behind the "water works" and there is no check valve where the hose connects to the flush connector. Keystone did tell me to look there to see if the valve was deffective or in backwards. Keystone also told me that the Challenger builders will very often change things during construction and it is difficult to keep up with their changes. Keystone customer support did not have any plumbing diagrams from Challenger.

exakpix

Oklahoma

Full Member

Joined: 10/19/2005

View Profile



Posted: 05/30/07 02:24pm Link  |  Print  |  Notify Moderator

Certainly don't know if your valve is behind the shower faucet or not, mine is, but sometimes you find them under the bathroom sink. I removed the 4 screws holding the shower faucet to the enclosure and gently pulled the faucet out...be careful, on mine the hot and cold and black tank rinse lines were tie wrapped together. Look around under your bathroom sink faucet first to see if it is there. Good luck.

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Fifth-Wheels

 > Challenger Black Tank Flush
Search:   Advanced Search

Search only in Fifth-Wheels


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS