RV.Net Open Roads Forum: Class A Motorhomes: Back Up Camera Repair

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes

 > Back Up Camera Repair

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
BobR

Aurora, Illinois

Senior Member

Joined: 12/07/2001

View Profile



Posted: 11/10/09 01:50pm Link  |  Print  |  Notify Moderator

I have a Sony SSC520AM camera in need of repair or replacement. Any suggestions on sources who repair the cameras?

DtBt

Saint Leonard, MD

Senior Member

Joined: 11/20/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/09 02:25pm Link  |  Print  |  Notify Moderator

Have you tried here for a replacement?


Dennis and Barb
2005 Safari Panther Diamond IV
1999 Monaco Windsor 40 SS (sold)
2002 Chevy Avalanche toad


6string

Springfield, Illinois

Full Member

Joined: 10/16/2003

View Profile


Offline
Posted: 11/10/09 02:53pm Link  |  Print  |  Notify Moderator

Not sure if you mean the camera or the monitor. My monitor went out. I called all around, found out it was discontinued and the new model wouldn't fit into the dash opening. Ended up calling a local TV repair shop and they fixed it for $20. Bad diode. Hope this helps.

BobR

Aurora, Illinois

Senior Member

Joined: 12/07/2001

View Profile



Posted: 11/10/09 05:27pm Link  |  Print  |  Notify Moderator

The camera is what I think is bad. The monitor powers up. The picture got wavy and then went out along with the sound. I appreciate the link but it is for a repair manual. I am in the same boat as 6string with a built in monitor and camera housing which limits options on replacements.

bigbubba1959

Illinois

Senior Member

Joined: 09/04/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/09 05:39pm Link  |  Print  |  Notify Moderator

hi you want want to speak with these guys....... they were easy to work with when I had issues with my system

RV CAM


if once you dont suuuceedd
If once you deont succeed
If once you dont succeed try tryyyy
If once you dont' succedd
Ok if once you dont succeed just freaking DO IT!!!!!!!!!!



corgidad

Virginia

Full Member

Joined: 10/11/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/09 05:55pm Link  |  Print  |  Notify Moderator

I second bigbubba's suggestion, contact Tim at RV cams he was very helpful to me and many others. He is great to deal with and will fix you right up

Bea PA

Waynesboro, PA, USA

Senior Member

Joined: 12/28/2000

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/09 06:56pm Link  |  Print  |  Notify Moderator

You didn't say what rig you have but on our 2004 the Sony was junk, replaced from Tim at 3 years.

1rooster

Warrenton, VA

Senior Member

Joined: 12/24/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 11/11/09 07:14am Link  |  Print  |  Notify Moderator

I had the same problem with my Weldex camera (06 Fleetwood Discovery). What I did is remove the rear camera from the coach and plugged it directly into the front camera. It worked. Then I resolved the cabling problem. If you need further info, please PM me.





BobR

Aurora, Illinois

Senior Member

Joined: 12/07/2001

View Profile



Posted: 11/11/09 07:46am Link  |  Print  |  Notify Moderator

Thanks for all the suggestions. My motorhome is a 1991 and the backup system is original. I did pull the monitor out of the dash and the 4 pin cable to the camera was plugged in properly. It is a one camera system so I don’t have the option of trying the camera at another location. I guess I will try to find a local repair shop.

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes

 > Back Up Camera Repair
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS