Open Roads Forum

Print  |  Close

Topic: onan micrilite 4000 generator

Posted By: jaswen69 on 09/20/10 06:23pm

My coach has a Onan 4000 microquiet gen, It runs fine till about 30 mins on the road then it shuts down and will not restart, it will turn over but wont fire up , this coach sat up a while before i purchased it, Im thinking the gas solenoid under the carb but not sure,I owned a small engine repair shop for years and seen a thousand of these solenoids go bad but this generator is a new animal to me,prbally needs a carb cleaning to. It runs fine till it gets hot. any input?


Posted By: tropical36 on 09/20/10 06:38pm

jaswen69 wrote:

My coach has a Onan 4000 microquiet gen, It runs fine till about 30 mins on the road then it shuts down and will not restart, it will turn over but wont fire up , this coach sat up a while before i purchased it, Im thinking the gas solenoid under the carb but not sure,I owned a small engine repair shop for years and seen a thousand of these solenoids go bad but this generator is a new animal to me,prbally needs a carb cleaning to. It runs fine till it gets hot. any input?

See if you can find the oil temperature shut down and disconnect it if you're sure that there is sufficient air flow. Look underneath for clogged screens, etc...and I would imagine that there's a fan output near the top somewhere.
Back to the temp sw. .....there should also be an oil pressure sw. that works in the same way in that they usually complete the circuit to ground when they close and kill the run circuit.
I'm only theorizing here and am not familiar with your unit, but it's worth a shot.
You didn't say if you had spark at the plugs or not. Also fuel pressure at the outlet of the pump assuming you have a fuel pump.


"We are often so caught up in our destination that we forget to appreciate the journey."

1998 36ft. National Tropi-Cal Model 6350 on a 1997 Chevy P32
Chassis_7.4 Vortec Engine_4L80E Tranny_slide_tag axle.

Dinghy_2010 Jeep Wrangler JKU ISLANDER.



Posted By: 96Bounder30E on 09/20/10 07:13pm

Post the serial number and spec letter and you will get Onan techs that will comment on your problem........without that info they have no idea what you have and probable won't comment......


I also have a PDF file repair manual that I can send you if you PM me your email address.....


Eric
96 Bounder 30E-F53(460)
stock Ford intake w/K&N air filter
used Thorley headers
new Banks resonator, muffler, tail pipe and 4" polished SS exhaust tip




Posted By: PapPappy on 09/20/10 07:16pm

Mine was cutting off after about 15 minutes....it's a 4KY model.
A previous discussion on this forum, and I did the following.
1.) Prior to running the genset, go to the outside start button.....it will have "prime" written above the "OFF/STOP" button.....when you push the button, you should hear the fuel pump running (clicking sound).
2.) Start the generator, and put a load (A/C unit) on it......
3.) when it shuts off, try that PRIME again, and see if you hear the pump running again......if not, the pump is bad, and you will need to replace it.

If the fuel has gotten stale, you may want to pull the fuel hose between the fuel tank and the fuel filter........and then get a couple of gallons of clean fuel, and add about a half bottle of SEA FOAM (You can get it at Walmart) and draw out of the gas can.....this will help clean out any of the******that is in the carb or the fuel lines. It will blow some serious stuff out the exhaust.

When was the fuel filter changed last? You may find that it's plugged up, and effecting operation....even causing the fuel pump to overheat and trip off.

How about the air filter?? If it's plugged, it will effect operation.
I don't know about any fuel solenoid....I don't think there is one on mine, but won't swear to it.

Good Luck......


Bill & Claudia / DD Jenn / DS Chris / GS MJ
Dogs: Sophie, Abby, Brandy, Kahlie, Annie, Maggie, Tugger & Beau
RIP: Cookie, Foxy & Gidget @ Rainbow Bridge.
2000 Winnebago "Minnie" 31C, Ford V-10
Purchased April 2008 FMCA# F407293
The Pets



Posted By: jaswen69 on 09/20/10 06:43pm

This onan is a bottomline unit , it has no oil shutdown features.


Posted By: bagmanx on 09/20/10 06:50pm

After it shuts off it should be giving you a blink code on the start switch. Count the blinks and check the manual or post back the results.

Hopefully it's telling you what's wrong.






Posted By: JohnnyT on 09/21/10 06:43pm

Moved from class A forum

* This post was edited 09/21/10 06:52pm by JohnnyT *


Posted By: tropical36 on 09/21/10 07:52am

jaswen69 wrote:

This onan is a bottomline unit , it has no oil shutdown features.

Hard to believe, but then an electrical schematic will easily confirm this.


Posted By: PapPappy on 09/20/10 07:19pm

I agree....the more information you can provide, the better.....


Posted By: jaswen69 on 09/20/10 07:49pm

Its a 4KYFA26100G, Im pretty sure it has no oil or temp S/D,very basic start/stop switch, A 5 amp fuse , and A breaker , the remote start has a rocker switch and an hour meter, Its a 98 model coach the Gen is the original with only 181 hrs, The prior owners rarely used it...


Posted By: jaswen69 on 09/21/10 05:37pm

I know its hard to believe but it has no low oil shutdown.I guess the good new is It has good fire but still wont run so Im looking at a fuel issue, Thats a little bit of comfort for me after reading all the electrical issues with these generators.


Posted By: Rettrooper on 09/24/10 06:28pm

jaswen69 wrote:

My coach has a Onan 4000 microquiet gen, It runs fine till about 30 mins on the road then it shuts down and will not restart, it will turn over but wont fire up , this coach sat up a while before i purchased it, Im thinking the gas solenoid under the carb but not sure,I owned a small engine repair shop for years and seen a thousand of these solenoids go bad but this generator is a new animal to me,prbally needs a carb cleaning to. It runs fine till it gets hot. any input?


Recently had the same problem. Someone on this forum mentioned putting Sea Foam in some gas and running it, let it sit for a day or two and restarting it. I did this and it started and ran under load for 30 mins. before I shut it off. Ran like a clock! I am very happy with it's performance. Try using the SEA FOAM and see if it'll cure your troubled Onan.


2013 Eagle Cap 1160
2006 Ford F-350 SD CC Diesel


Print  |  Close