RV.Net Open Roads Forum: Dometic ref. not running after unlevel for 5 days

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Dometic ref. not running after unlevel for 5 days

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next
Sponsored By:
America_west

Washington

New Member

Joined: 08/30/2007

View Profile


Offline
Posted: 11/20/11 06:05pm Link  |  Print  |  Notify Moderator

I had no choice but to operate my Dometic ref. for 5 days being unlevel about 3 inches. Now it only runs for a couple mins and totally shuts down. Do I have to leave it set level for a period of time, or will it need service or replacing? It's been level now for 4 days, and it still shuts down after a short period of time.
Ron

tvman44

Southwest Louisiana

Senior Member

Joined: 09/25/2007

View Profile


Offline
Posted: 11/20/11 06:07pm Link  |  Print  |  Notify Moderator

Might be time for a new cooling unit because of blockage.


Papa Bob
1* DW "Granny"
1* 2008 Brookside by Sunnybrook 32'
1* 2002 F250 Super Duty 7.3L PSD
Husky 16K hitch, Tekonsha P3,
Firestone Ride Rite Air Springs, Trailair Equa-Flex, Champion C46540
"A bad day camping is better than a good day at work!"


mena661

Southern California

Senior Member

Joined: 03/21/2009

View Profile


Offline
Posted: 11/20/11 06:16pm Link  |  Print  |  Notify Moderator

My fridge is always unlevel when at home. I fire it up before a trip and run it for a couple days without leveling with no issues.


2009 Newmar Canyon Star 3205, Ford F53 V10
Trojan L16 6V's 740 Amp-hours


Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 11/20/11 06:20pm Link  |  Print  |  Notify Moderator

Sounds like you may have 'no choice' but to replace it.
From your description the cooling unit has probably clogged from the unlevel operation. When unlevel and operated the 'coolant' flow can be blocked and then crystallizes from the heat clogging the cooling unit.

A reported fix is to remove refrigerator, turn it up side down for 24 hrs. and then reinstall......supposedly breaks up the clog and redistributes the coolant. But sounds like a temporary fix as crystals are still in system and will clog unit again.

Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 11/20/11 06:23pm Link  |  Print  |  Notify Moderator

mena661 wrote:

My fridge is always unlevel when at home. I fire it up before a trip and run it for a couple days without leveling with no issues.

A little unlevel....no real problem

But 'unlevel' (several inches off level as OP stated)..you are running on borrowed time....and you have a fairly new unit. Hope you don't have to replace it soon

Wills250psd

walnutcove NC

Senior Member

Joined: 08/13/2011

View Profile



Good Sam RV Club Member


Posted: 11/20/11 06:23pm Link  |  Print  |  Notify Moderator

The TT we have now the fridge will work out of level fine, the last 5er would not work unless level, you may have a problem, hope it dont cost much to get fixed good luck!! Will

sch911

Rochester Hills, MI

Senior Member

Joined: 04/13/2003

View Profile



Posted: 11/20/11 07:01pm Link  |  Print  |  Notify Moderator

Jack_Diane_Freedom wrote:

I had ana Dometic do that a few years ago. I was told by a technician to take a large screwdriver by the blade and bang the 'U' returns on the outside of the unit to loosen up the crystalization. Worked fine after I did that.


I had that work once on an older unit also....


OEM Auto Engineer
2003 Damon Challenger 348 Class A - F53 Triton V10
2007 Jeep Grand Cherokee Limited 4x4 V8 Toad


zip0

NY

Senior Member

Joined: 03/14/2002

View Profile


Offline
Posted: 11/20/11 06:25pm Link  |  Print  |  Notify Moderator

OK not sure if this will work but a few years ago I watched a guy in a CG do this. He took his fridge out of his TT, turned it upside down for a few hours, then flipped it back over and reinstalled it. He claimed that it will dislodge the blockages in the system. The next day he told me it was working like new.

Hey if you have to remove it to install a new cooling unit what can it hurt to give it a try first.

If you do and it works let us know.


" A day without camping is....WORK"

2003 Bounder 35R
3 Jack Russell's


Jack_Diane_Freedom

Milton Ontario Canada

Senior Member

Joined: 05/11/2005

View Profile


Offline
Posted: 11/20/11 06:25pm Link  |  Print  |  Notify Moderator

I had ana Dometic do that a few years ago. I was told by a technician to take a large screwdriver by the blade and bang the 'U' returns on the outside of the unit to loosen up the crystalization. Worked fine after I did that.

Chuck&Gail

In the Colorado Mountains

Senior Member

Joined: 06/16/2004

View Profile



Good Sam RV Club Member


Posted: 11/20/11 06:26pm Link  |  Print  |  Notify Moderator

Are you handy? Some folks have reportedly had good luck removing the fridge, turning it upside down, and leaving it that way for 24 hours, then reinstalling. Never tried it myself.


Chuck
Wonderful Wife
Australian Shepherd
2010 Ford Expedition TV
2010 Outback 230RS Toybox, 5390# UVW, 6800# Loaded
Not yet camped in Hawaii, 2 Canada Provinces, & 2 Territories
I can't be lost because I don't care where this lovely road is going

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next

Open Roads Forum  >  Tech Issues

 > Dometic ref. not running after unlevel for 5 days
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS