Open Roads Forum

Print  |  Close

Topic: Winnebago Vista entry step problem

Posted By: charles on 12/08/11 05:10pm

Today I opened my entry door (2011 Winnebago Vista 35F) and the steps didn't open and the step light didn't come on. I have both the chassis and coach battery switches in the on position and the step switch in the on position. I turned the ignition key one click and the steps worked. Everything else on 12 volt seems to be working but the steps will now only work if the ignition key is on. I posted this on another forum and someone with a Itasca said they had the same problem and it was a bad battery. I don't quite understand how that could be especially since this is a new unit and is plugged into shore power.

Any suggestions?

Thanks

Nick


2012 Pleasure-way Excel TS


Posted By: winnehonda on 12/08/11 05:16pm

Have you tried to reset the 12volt circuit breakers? On mine they are loctated in the propane tank compartment.


Mark Hanlon


Posted By: charles on 12/08/11 05:27pm

I did check the breakers inside the unit and all were OK. I didn't realize there were others to look at but I'll try looking around tomorrow. The owners manual is a little hard to understand. If I can't figure it out here I'll try calling Winnebago and hope they have an answer without me taking it in as I keep it in heated storage and don't winterize it.

Nick


Posted By: tatest on 12/08/11 05:52pm

The retractable steps are powered from the chassis battery rather than the house battery, to enable a safety over-ride feature. They should retract when the ignition switch is turned on while the door is closed, even if the step switch is "off" (that's the feature). But I thought that's just a signal from the switch position, as they are normally powered from an "always powered" circuit. Maybe they get power from the "ignition on" position too.

If my steps don't come out when I open the door after storage, it is sure sign that the chassis battery is down, and I'll be boosting or charging to start the thing.

With what yours are doing, I suspect a problem with the "always on" circuit, a breaker, fuse, or fusible link. It's not the battery, because they are doing the something when ignition is on.

One source of information might be the installation manual from the step manufacturer (should be in the black bag). It will show how the steps are wired, but won't show where the circuit connections are on the chassis, or how they are protected. Might need a chassis service manual for that.


Tom Test
Itasca Spirit 29B



Posted By: LadyRVer on 12/08/11 06:19pm

If you have Kwikee steps, they have an excellent customer service department.
They have walked me through some problems over the phone.


Posted By: vtbig on 12/09/11 07:43am

You said you had the step switch in the "On position". Try turning it off and see if the step works. The "On position" you refer to may be leaving the step in the last position it was in. For example if the step is deployed or retracted , throwing the switch would leave it in that position. The ignition switch would override this.

If not I would check the magetic switch in the door jamb as it sounds like it may be out of alignment with the magnet in the door. Place a magnet against the jamb and see if the step works with the ignition or or off.


Posted By: jy on 12/09/11 07:59am

I think your chassis battery is low. When you turn the ign. key on a solenoid engages that ties the batteries togeather so the engine will charge the house batteries when running.What it is doing now is taking power from the house batteries to the chassis battery which runs the steps. Most class a's don't charge the chassis battery when plugged in to shore power.JMO


99 Coachmen 322QB, Ford V10,18 foot Load King open trailer, 2007 Mustang GT Toad, Gibson exhaust,Royal Purple lubricants.Recently retired and planning on doing more RV'ing.



Posted By: Clay L on 12/09/11 08:47am

LadyRVer wrote:

If you have Kwikee steps, they have an excellent customer service department.
They have walked me through some problems over the phone.


That used to be true but after they were bought by the company (Actuant)that owns PowerGear and folded into PowerGear their customer service became nonexistent and they will not talk to customers.

I understand that PowerGear technical customer service will answer emails though.


Clay (WA5NMR), Lee (Wife), Katie & Kelli (cats).

Fixed domicile after 1 year of snowbirding and eleven years Full Timing in a 2004 Winnebago Sightseer 35N, Workhorse chassis, Honda Accord toad


Posted By: charles on 12/09/11 11:44am

OK, went back over today and the chassis battery was dead, again, this is a new unit and I checked the battery water level several weeks ago. I used the jumper switch to start the motor and watched the amp. gauge, it was below center if that means anything. After 10 minutes I turned it off and the battery seemed strong and it restarted easily. However, the steps still don't open or close and now not even with the key turned on. I checked with Winnebago and they said if there is power to the motor, which there was yesterday that there is something wrong in the "brain box" under the steps or at the breakers, they weren't really helpful. I did find the breakers marked "steps" and they were not tripped. Any suggestions for both the steps and why the battery was dead?

Thanks,

Nick


Posted By: Clay L on 12/10/11 09:39am

You can go HERE, scroll down to the blocks where you send them a message and ask them for "Electric Step Manual #888". That should have a trouble shooting guide in it. It used to be on the old Kwikee web site which now routes you to the PowerGear site.
There are two Kwikee documents on the Powergear web site you might want to download but I couldn't find the trouble shooting document.

There is a trouble shooting guide on THIS SITE that looks like a good one.


Also if you send me a private message with your email address I will send you a Word document containing the Kwikee trouble shooting guide.


Posted By: 2bzy2c on 12/10/11 04:19pm

In my experience, the steps will not work correctly if the battery voltage is low. Sometime the will not extend, or only extend part way. Once you get your battery issue resolved, that should take care of your step problem.


My advice is worth exactly what you paid for it.


Posted By: badger47 on 12/10/11 05:50pm

I believe you asked two questions. Lots of excellent help on the steps operation, but not much on why your battery is dead. It sounds like your unit is in storage and connected to shore power(?). Please note that your chassis battery is not being charged while on shore power. It does not take very long for the parasitic draws - radio, gas detector, maybe your antenna booster, to kill your chassis battery or at least draw it down to where it acts dead. Recommend you install a TRIK-L-START http://www.lslproducts.com/TLSPage.html or like device. If your chassis battery has already been drawn down twice it may already be damaged somewhat and have a shorter life expectancy.


Winnebago Vista 35F
Equinox behind



Posted By: charles on 12/11/11 09:20am

I went over this morning and now that the power to the steps was disconnected, the battery held it's charge. I connected the power to the steps and they did nothing. I left them connected and tomorrow will check the battery again, if it's dead I would assume that the step motor is drawing it down. Also, the step light doesn't come on although that might be because the steps are in instead of out.

I checked the battery before I started the motor and it was at 11.25 volts and with the motor running it was at 11.5 volts and the dash meter was all the way down to charge and came up about 30% after 20 minutes or so. 11.25 is also where the house batteries are so I don't know if my meter is registering a little low or they actually are all under 12 volts. The shore power was plugged in all night so the house batteries should have been fully charge when showing 11.25

I hope you can understand this as I know only a little about batteries and may not be stating things the way that I should.

???

Nick


Posted By: 2bzy2c on 12/11/11 04:27pm

I think you have a low voltage problem. 13.6 is the normal voltage while the car is running. + or - .5 volts


Posted By: vtbig on 12/11/11 05:14pm

I'm telling you...I would check that switch by the door. If the steps work with the engine running and do not work otherwise, that switch may either be in the wrong position or bad.


Posted By: 2bzy2c on 12/11/11 08:06pm

vtbigdog wrote:

I'm telling you...I would check that switch by the door. If the steps work with the engine running and do not work otherwise, that switch may either be in the wrong position or bad.


Or, the low voltage condition is not allowing the steps to work unless the engine is running. I had the same problem, and it was bad batteries, but it would not hurt to do as vtbigdog suggests.


Posted By: charles on 12/12/11 11:50am

On my second post I mentioned that they would not open even with the key on. Anyway, I connected everything yesterday and hit the battery disconnect switch so that power was only going to the door and nothing else, I went over this morning and the battery held it's charge, but only 11.25 volts. I turned the battery disconnect back on, steps still wouldn't work, started the engine and left it run for exactly one hour, still 11.25 volts. I hooked up a 12 volt transformer right to the step motor, it hummed very slightly but didn't move don't know if the transformer was strong enough as I had to run about 6 feet of 14 gauge wire from it to the motor.

Do you think I should pull the battery and put in a fresh one out of my car just to try the steps? Or take it somewhere and get it tested before I go any further?

Nick


Posted By: Clay L on 12/12/11 01:22pm

If it is a transformer it will put out AC which won't operate a DC motor. If it is a wall-wart that rectifies the AC and puts out DC it may not provide enough current to operate the motor.

The first thing you probably want to do is find out why your batteries are not being charged.
Are you measuring the 11.5 volts on the chassis battery or on the house batteries?
On shore power the house batteries should be charging at about 13.5 volts. On most models Winnebago wires them so that there is only one battery disconnect switch and it is on the house battery.

Your chassis batteries should be charging at about 14.4 volts from the alternator. The house batteries will also charge from the alternator via a continuous duty solenoid/relay activated by the run terminal on the ignition switch or by the momentary AUX Start switch on the dash.

I would get the battery charging problem fixed first and then see if there is still a step problem.


Posted By: charles on 12/12/11 02:29pm

The 11.5 is on all three batteries and again, my volt meter is old and may not be accurate, I wen't to NAPA today to buy a new one and they were out of them. When the motor is running the chassis battery reads 11.5. There are two different battery disconnects on this model, one for the coach batteries and one for the house battery.

I'm taking them to a local Crown Battery shop tomorrow to have them checked out. I sure hope it's the battery as that would be a simple fix.

I'll update tomorrow.

Nick


Posted By: zman-az on 12/12/11 05:03pm

Buy a decent battery charger for around $50 or so, something every homeowner should have in there garage. Then disconect the battery and put on the charger overnight. You can check your voltmeter by taking it to your car battery (assuming your car is working) and measure the voltage there. If its 11.5 your meter is bad, get a new one. Once you know your batteries are fully charged then you can try and trouble shoot the steps.






Posted By: Daboo on 12/12/11 06:03pm

I have an 03 Winnebago and the steps are tied into the rear view tv...check the rear camera and see if it works,it is a 15 amp fuse under the dash, good luck


Served proudly 1957-1965..U.S. Air Force


Posted By: charles on 12/14/11 10:44am

I put a 6 amp charger on the battery after taking off the cables and charged it for 24 hours. This morning it read 13.42 volts, two hours later 13.22 volts so holding for at least the two hours. I then hooked up the cables, turned the key one click and the dash gauge was all the way down. Started the engine and checked the voltage and it was 14.45 at the battery so I assume not an alternator problem. However, steps still would not open and light does not come on with door switch in either position. I called Winnebago again and this service rep. right away told me that there is a in-line resister in a harness that will go out if high voltage goes through the line to protect the controller box, said they started using these two years ago. He is sending one to replace it. My thoughts are what would have caused higher voltage to go through the harness and trip the resister? I didn't put a charger on the battery until yesterday. I didn't try the magnet thing yet because I have to find my magnet.

I sure hope this works,

Nick


Posted By: charles on 01/23/12 12:47pm

Well, I'm now in Florida and after resting up a few days a crawled back under the steps with the levellers down, lot more room to work,disconnected all of the electrical connectors. cleaned them the best I could, put it all back together and now they work. Assumption, either one was loose or they needed cleaned, hope it keeps on working, one less thing for the dealer.

Nick
2011 Winnebago Vista 35F


Print  |  Close