RV.Net Open Roads Forum: Travel Trailers: Brake Controller Question

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Travel Trailers

Open Roads Forum  >  Travel Trailers

 > Brake Controller Question

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
ForestRiverTeach

Azusa, CA, USA

Senior Member

Joined: 11/08/2004

View Profile



Posted: 01/15/12 08:03pm Link  |  Print  |  Notify Moderator

I don't know where to post this, so I'll apologize in advance if it's in the wrong spot.

I've just traded vehicles, going from an Explorer to an Expedition. I'm delighted with the Expedition's towing capacity and will feel much more comfortable towing my little 19' Keystone Hideout.

When I traded in the Explorer I had the dealer remove my Prodigy brake controller (please don't ask me for the model# -- I don't have a clue) and install it in the Expedition. It was an easy install -- just "plug and play" from what I could see. But here's my question:

When I turn off the Expedition there are 2 little red "dots" that stay on for a good 15-20 min. after I've closed up the car. I don't remember if this happened in the Explorer or not. Is this typical? Should I take it back to the dealer & have them check out stuff? I'm going to take it by the trailer tomorrow & hook it up to see if I get my normal readout, and if I don't it's going back to the dealer.

Any insight on this would be helpful. Thanks!


On the road and happy with Jed, my four-legged camping buddy.
'06 Eddie Bauer Expedition
'13 Starcraft 265RLB Autumn Ridge

anaro

Mebane, NC

Senior Member

Joined: 01/16/2011

View Profile



Good Sam RV Club Member


Posted: 01/15/12 08:22pm Link  |  Print  |  Notify Moderator

I think my P3 stays on for a little bit but it is the entire screen not just 2 red dots.


2014 Silverado 3500 Duramax, SRW, Crew Cab, 4WD
2014 Palomino Sabre 34REQS - 5 nights camped
2011 Crossroads Zinger ZT26BL - sold after 3 1/2 yrs and 76 nights camped in it!

Chuck&Gail

In the Colorado Mountains

Senior Member

Joined: 06/16/2004

View Profile



Good Sam RV Club Member


Posted: 01/15/12 08:31pm Link  |  Print  |  Notify Moderator

Normal. Two dots means boost is on. No problem IMO.


Chuck
Wonderful Wife
Australian Shepherd
2010 Ford Expedition TV
2010 Outback 230RS Toybox, 5390# UVW, 6800# Loaded
Not yet camped in Hawaii, 2 Canada Provinces, & 2 Territories
I can't be lost because I don't care where this lovely road is going

wmoses

Houston, Texas, USA

Senior Member

Joined: 07/17/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 01/15/12 09:52pm Link  |  Print  |  Notify Moderator

ForestRiverTeach wrote:

When I turn off the Expedition there are 2 little red "dots" that stay on for a good 15-20 min. after I've closed up the car. I don't remember if this happened in the Explorer or not. Is this typical?

I have a Prodigy P3 and it stays on for about 15 minutes after I shut off the truck. I suspect yours is doing likewise.


Regards,
Wayne
2014 Flagstaff Super Lite 27RLWS Emerald Ed. | Equal-i-zer 1200/12,000 4-point WDH
2010 GMC Sierra 1500 SLE 5.3L | K&N Filter | Hypertech Max Energy tune | Prodigy P3
_


pasusan

Northernmost PA

Senior Member

Joined: 05/13/2009

View Profile



Posted: 01/16/12 06:01am Link  |  Print  |  Notify Moderator

Sounds like you have a P2 - that's what we have and the 2 little red dots do stay on for a while. Not to worry!


Trip Pics

"I'm out here to enjoy nature -- don't talk to me about the environment!" ~Denny Crane

Susan & Ben ~
84 Bronco & 90 Award Classic 23 joined with a Hensley Cub


'tiredTeacher

Richmond, VA

Senior Member

Joined: 09/22/2005

View Profile



Good Sam RV Club Member

Online
Posted: 01/16/12 07:01am Link  |  Print  |  Notify Moderator

ForestRiverTeach wrote:

When I turn off the Expedition there are 2 little red "dots" that stay on for a good 15-20 min. after I've closed up the car. Is this typical?

Yes. The manual states that the unit will put itself "to sleep" in about 15 min.

Rest easy,
Teach


Wright and Penny
2010 Tundra 4X4
2005 Starcraft 2107
2014 Rockwood 2604WS
"Life is a cruel teacher. She gives the test first; the lesson then follows."

Terryallan

Foothills NC

Senior Member

Joined: 06/28/2004

View Profile


Offline
Posted: 01/16/12 07:33am Link  |  Print  |  Notify Moderator

Yes it's normal, they will go off after a while, and will come back on as soon as you touch the brake pedal. Hooked to the trailer or not.


Terry & Shay
Coachman Apex 288BH.
04 F150, 5.4, Lariat SuperCab
Lazy Campers


ForestRiverTeach

Azusa, CA, USA

Senior Member

Joined: 11/08/2004

View Profile



Posted: 01/16/12 07:47am Link  |  Print  |  Notify Moderator

Thanks for your response, everyone. I've had the controller for several years and have moved it to different cars twice so the owner's manual has disappeared. It's nice to know that when it can't be found there are lots of human "manuals" here that are more than willing to help out.

RoyB

King George, VA

Senior Member

Joined: 04/13/2008

View Profile



Good Sam RV Club Member


Posted: 01/16/12 08:20am Link  |  Print  |  Notify Moderator

here you go...



P2 PRODIGY MANUAL
P2 PRODIGY MANUAL
P2 PRODIGY MANUAL


My Posts are IMHO based on my experiences - PM me
Roy and Carolyn
RETIRED DOAF/DON/DOD/CONTR RADIO TECH (42yrs)
K9PHT (Since 1957) 146.52M
2010 F150, 5.4,3:73 Gears,SCab
2008 Starcraft 14RT EU2000i GEN
2005 Flagstaff 8528RESS
POPUP PHOTOs-Pg52


This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Travel Trailers

 > Brake Controller Question
Search:   Advanced Search

Search only in Travel Trailers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS