RV.Net Open Roads Forum: inverter shuts down when I plug TT power cord into it

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > inverter shuts down when I plug TT power cord into it

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 5  
Prev
Sponsored By:
christopherglenn

Near Yosemite

Senior Member

Joined: 02/16/2009

View Profile


Offline
Posted: 02/26/12 11:20pm Link  |  Print  |  Notify Moderator

The inverter may be detecting the DC neg shorted to the ac ground. Try one of these, put it between the inverter and the shore power cord.


2007 Chevrolet 3500 CC/LB Duramax/Dually 4X4 Mine r4tech, Reese Signature Series 18k +slider, duratrac, Titan 62 gallon, diamond eye, Cheetah 64
2011 Keystone Fusion 405 TrailAir & Triglide, Centerpoint, gen-turi, 3 PVX-840T, XANTREX FREEDOM SW3012, G614


BFL13

Victoria, BC

Senior Member

Joined: 02/15/2006

View Profile



Posted: 02/27/12 07:39am Link  |  Print  |  Notify Moderator

Vector charger manual shows that type of adapter to by pass the ground prong, and says, "use of an adapter (of that type) is not allowed in Canada" It says this type of adapter is for temporary use only until a properly grounded outlet can be installed. Also the two- prong outlet (to be replaced ASAP) must have the centre screw of its outlet plate grounded--ISTR some receptacles use plastic boxes.


2003 Chev 2500HD Gas, 2003 Komfort 26FS 5er
See Profile for Equipment List

ewarnerusa

Helena, Montana

Senior Member

Joined: 12/20/2011

View Profile


Offline
Posted: 03/06/12 08:46pm Link  |  Print  |  Notify Moderator

Good news, the new 300W pure sine wave inverter doesn't trip any faults and powers up the TT just like I want it. The TV has no buzzing of any kind. Unfortunately, the 1000W pure sine wave inverter did have the TV making a little bit of buzzing. The buzzing is not near as bad or loud as the with the modified sine wave inverter, but it seemed similar. The 1000W was just using the thin power cables that came with the 300W inverter, but I was only pulling the same amount of watts that I was from the 300W inverter. The power wires are about 2 feet long clamped directly to the battery via alligator clamps. I plan on doing a proper inverter install with 0 gauge power wire, but right now I'm just making sure the system will work like I want it to. The are both the same brand inverter from the cheap ebay source. Did I get what I paid for with the 1000W one?


Aspen Trail 2710BH | 280 watts of solar | 2x 6V GC batteries | 100% LED lighting | 1500W PSW inverter

mena661

Southern California

Senior Member

Joined: 03/21/2009

View Profile


Offline
Posted: 03/06/12 10:47pm Link  |  Print  |  Notify Moderator

Excellent! Glad it worked for you.


2009 Newmar Canyon Star 3205, Ford F53 V10
Trojan L16 6V's 740 Amp-hours


shooted

Pacific Northwest

Senior Member

Joined: 06/17/2011

View Profile



Posted: 03/07/12 10:09am Link  |  Print  |  Notify Moderator

Nice! Can you confirm a UL listing difference between the inverters that worked and the one that did not? Maybe others can avoid having a similiar problem if we can isolate this issue to the UL458 standard.

shooted

Pacific Northwest

Senior Member

Joined: 06/17/2011

View Profile



Posted: 03/24/12 09:20pm Link  |  Print  |  Notify Moderator

.

Jonesz

Minnedosa

Full Member

Joined: 03/25/2010

View Profile


Offline
Posted: 03/24/12 09:51pm Link  |  Print  |  Notify Moderator

What brand 300 W PSW inverter did you buy? I have had the same issues you have had. Borrowed my friends 750 W MSW inverter (Black and Decker) plugged it into my shore power cord and everything that I needed worked as planned. I have bought 3 similar sized units of differing brands and they have all faulted. Only want to drive my radio and TV and a small reading light. If I hook up to my truck everything is OK-if I hookup my shore power chord to my trailer batteries it shuts down? I shut off my breakers to everything but the wall plug circuits.
Jonesz

ewarnerusa

Helena, Montana

Senior Member

Joined: 12/20/2011

View Profile


Offline
Posted: 03/24/12 10:15pm Link  |  Print  |  Notify Moderator

The cheap ebay source that is mentioned on these forums.
Click

allen rvtech

chilliwack bc

New Member

Joined: 03/28/2012

View Profile


Offline
Posted: 03/29/12 01:01am Link  |  Print  |  Notify Moderator

chassis ground to case of inverter

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 5  
Prev

Open Roads Forum  >  Tech Issues

 > inverter shuts down when I plug TT power cord into it
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS