RV.Net Open Roads Forum: Class C Motorhomes: E450 Cruise Control

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Class C Motorhomes

Open Roads Forum  >  Class C Motorhomes

 > E450 Cruise Control

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
Sponsored By:
Tonijim

MA

Senior Member

Joined: 04/12/2004

View Profile



Good Sam RV Club Member


Posted: 03/05/12 06:52pm Link  |  Print  |  Notify Moderator

We have an'02 Ford E450 for our '03 BT Cruiser(60,000 miles). On the way to Fl this year our cruise control stopped working. The "On" switch didn't come on and the "Set" switch didn't either. The #6 fuse had not blown.

Any thoughts would be appreciated.

Jim





j-d

Sunny Florida USA

Senior Member

Joined: 09/04/2003

View Profile



Good Sam RV Club Member

Online
Posted: 03/05/12 08:59pm Link  |  Print  |  Notify Moderator

Only two guesses.
1. Brake pedal release not closing when foot is off the brake
2. VSS (Vehicle Speed Sensor) on top of differential housing failed
A site like BATAUTO.COM (Domestics Forum) might be a better place to ask, or even RV.Net's Tech Forum. This is like most other Ford cruise controls so you don't want to limit the question to just a Class C forum.


If God's Your Co-Pilot Move Over, jd
2003 Jayco Escapade 31A on 2002 Ford E450 V10 4R100 218" WB

rustell

Mount Vernon Wa.

New Member

Joined: 05/05/2010

View Profile


Offline
Posted: 03/06/12 10:59am Link  |  Print  |  Notify Moderator

I'm interested to see if this thread goes anywhere...Most of the time mine doesn't work..I will be driving along and out of the blue hit the switch and it works,usually when we are almost to our destination.. I have never seen the dash indicator light up.

NewsW

US

Senior Member

Joined: 02/06/2012

View Profile



Posted: 03/06/12 11:06am Link  |  Print  |  Notify Moderator

Easy.

You can do diagnostics, or you can just replace the cruse control deactivation switch.

It is on the lower side of the master cylinder, a screw on / in part.

Note proper job (not hatchet) require complete bleeding of the brakes.

Might as well do a complete brake fluid change at same time.

There was a batch of bad ones that replaced the original fire prone one.

You got one of them.


If the switch is good... then we are onto more complex cases.

dufferdj

Colorado/Arizona

New Member

Joined: 07/27/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 03/06/12 11:56am Link  |  Print  |  Notify Moderator

We have both a '96 and '02 Ford Explorer that had recalls on the cruise controls. Took both into the dealer and they were replaced/repaired for free. There was a safety/fire issue with them. Your problem may not be the same, but it would be worth a phone call to your local Ford dealer.

NewsW

US

Senior Member

Joined: 02/06/2012

View Profile



Posted: 03/06/12 07:06pm Link  |  Print  |  Notify Moderator

dufferdj wrote:

We have both a '96 and '02 Ford Explorer that had recalls on the cruise controls. Took both into the dealer and they were replaced/repaired for free. There was a safety/fire issue with them. Your problem may not be the same, but it would be worth a phone call to your local Ford dealer.



That is the cruise control deact switch.

You got one of the replacements, early batches for first few years was a dud, didn't catch fire again, but just failed.

genesimmons

n.c.

New Member

Joined: 11/26/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 03/06/12 11:08pm Link  |  Print  |  Notify Moderator

also check turn signals, my turn signal switch went bad on mine and that kept the cc from working

HEMIDAZE

Amelia, OH

Senior Member

Joined: 03/30/2004

View Profile


Offline
Posted: 03/07/12 09:35am Link  |  Print  |  Notify Moderator

There is a safety recall on your unit (and thousands of other Fords) concerning fires as a result of a defective cruise switch. Check with your dealer. If yours hasn't been fixed they will fix it for free.


2002 Jayco Greyhawk 31RB
2011 HHR (picture coming)


Heish

United States

Full Member

Joined: 10/25/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 03/09/12 01:59pm Link  |  Print  |  Notify Moderator

Hemidaze, Thanks for the information on that. My cc stopped working AND my ABS light is on. Called my local Ford dealer and got an appointment. Hope that is what it is! Love this site!

j-d

Sunny Florida USA

Senior Member

Joined: 09/04/2003

View Profile



Good Sam RV Club Member

Online
Posted: 03/10/12 05:10am Link  |  Print  |  Notify Moderator

Hiesh,
By all means find out it the cruise control recall was done on your chassis. The ABS light being on and cruise not working points strongly to the VSS having failed, though. At least on pre-OBD2 Fords, 1995 or so and earlier.
The VSS went out in 1992 AeroStar and we lost Cruise, Odometer, and Overdrive. ABS light was ON.

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Class C Motorhomes

 > E450 Cruise Control
Search:   Advanced Search

Search only in Class C Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS