RV.Net Open Roads Forum: Tech Issues: Help--Generator Starting on it's own !

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Help--Generator Starting on it's own !

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
USMC46

Texas

Senior Member

Joined: 08/31/2006

View Profile



Good Sam RV Club Member

Offline
Posted: 03/09/12 07:32pm Link  |  Print  |  Notify Moderator

I returned home this evening and after a few minutes heard someting like a truck in my back yard. No truck...my Onan diesel generator in my coach was running. It had started on it's own. I went inside and switched the toggle switch to turn it off and it turned off. Any ideas ? Bad toggle switch maybe ?


Jim & Carmel
http://sayreodyssey.blogspot.com/
2004 Dutch Star 41'
2006 Jeep Liberty
Blue Ox Aventa Tow Bar
Brake Buddy

rexlion

Broken Arrow OK

Senior Member

Joined: 04/01/2005

View Profile



Posted: 03/09/12 07:46pm Link  |  Print  |  Notify Moderator

Not sure what started it, but you might want to pull the spark plug wire off until you get it diagnosed.

past-MIdirector

Michigan

Senior Member

Joined: 03/03/2007

View Profile





Offline
Posted: 03/09/12 07:48pm Link  |  Print  |  Notify Moderator

Is your rig equipped with a low battery auto start generator? A lot of the newer rigs are equipped with this system.





wolfe10

Texas

Senior Member

Joined: 10/08/2000

View Profile


Online
Posted: 03/09/12 07:49pm Link  |  Print  |  Notify Moderator

If no auto gen set start, check for water in your on-generator start switch or wiring at the generator end of the wires that go to the in-coach start switch.


Brett Wolfe
2003 Alpine 38'


FMCA Forum: www.community.fmca.com/index

Diesel RV Club:http://www.dieselrvclub.org/

steveownby

Cosby, TN

Senior Member

Joined: 09/23/2009

View Profile


Offline
Posted: 03/09/12 07:51pm Link  |  Print  |  Notify Moderator

I assume you don't have auto gen start. Onan 7.5kw generators have been known to self start if moisture gets into the multi wire plug on the outside of the generator box. You might shoot some di-electric grease into the plug.


Steve Ownby
2003 Monaco Signature

Full-time since 2007


ohio4whlr

central ohio

New Member

Joined: 01/07/2012

View Profile


Offline
Posted: 03/09/12 08:13pm Link  |  Print  |  Notify Moderator

rexlion wrote:

Not sure what started it, but you might want to pull the spark plug wire off until you get it diagnosed.


Diesel gen. No spark plugs, also just pulling plug wire won't keep it from cranking.

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 03/09/12 08:28pm Link  |  Print  |  Notify Moderator

rexlion wrote:

Not sure what started it, but you might want to pull the spark plug wire off until you get it diagnosed.


1. Diesels do NOT have spark Plugs
2. BAD IDEA, If it cannot start, what happens to the starter or ring gear???????
3. To the OP, DISCONNECT the remote harness at the APU and check for corroded pins inside that connector. Onan Diesel remote connects at the APU are notorious for corroding out even with the rubber seals on the matching plugs.
4. If it starts after the remote plug is checked (OK) and you leave it disconnected, then water got into the switch/breaker housing area. Some Onan Diesels will start if water gets inside that housing. Doug

TEXAS

Centerville Tx

Senior Member

Joined: 08/17/2003

View Profile



Posted: 03/10/12 06:36am Link  |  Print  |  Notify Moderator

You guys take it easy on the spark plug guy. He is from Oklahoma.

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Help--Generator Starting on it's own !
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS