RV.Net Open Roads Forum: 95' Pace Arrow Ford - Speedometer/Mileage gone

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes

 > 95' Pace Arrow Ford - Speedometer/Mileage gone

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
etmorrison

Hilton Head, SC

Full Member

Joined: 08/06/2006

View Profile


Offline
Posted: 06/13/12 08:16am Link  |  Print  |  Notify Moderator

All the sudden my Speedometer reads all the way over past 80 MPH and the digital mileage display is blank. All the other gauges read fine dash lighting working fine. Help!

Morrisonhhi@aol.com


ET & Connie Morrison
Hilton Head Island SC

RLS7201

Very Very

Senior Member

Joined: 10/26/2002

View Profile


Offline
Posted: 06/13/12 08:37am Link  |  Print  |  Notify Moderator

On you transmission's ZF emergency brake assemble is your Vehicle Speed Sensor (VSS). It sends a signal to the PSOM, located on the dash. The VSS's signal also goes to the ECM, and controls transmission shifting. The PSOM is what drives the speedometer. If your transmission is shifting funny, then the VSS is probably at fault.

Richard

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes

 > 95' Pace Arrow Ford - Speedometer/Mileage gone
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS