RV.Net Open Roads Forum: Tech Issues: Atwood 8531-iv dclp furnace won't fire

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Atwood 8531-iv dclp furnace won't fire

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
robfad

home

New Member

Joined: 01/21/2013

View Profile


Offline
Posted: 01/21/13 04:17pm Link  |  Print  |  Notify Moderator

I am getting no ignition on my Atwood 8531-iv dclp furnace. I have good gas supply. When I turn the thermostat to heat and set the temp. to say 70, the fan comes on for about 30 seconds. I used to hear the igniter spark when I set the thermostat and could hear the flame kick in when the thing worked. Now just a short fan cycle and nothing. I do notice that there is a red LED flashing on the control board after the fan stops turning. Any help will be greatly appreciated.

Rob

Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 01/21/13 04:57pm Link  |  Print  |  Notify Moderator

LED Light

Internal Circuit Board Failure......Steady on (no flash)
Limit switch/Airflow problems.......1 flash with 3-second pause
Flame Sense Fault...................2 flashes with 3-second pause
Ignition Lockout Fault..............3 flashes with 3-second pause

How many/often is LED Flashing?

BLOWER RUNS - BUT FAILS TO IGNITE
Low Voltage/High Voltage ----------------------Correct Power Supply*
Gas pressure incorrect --------------------------Set pressure to a minimum of 11? W.C. with all appliances running. (Replace regulator if not obtainable).*
Furnace grounding wires not secure --------Clean and secure grounds established*
Air intake restricted ------------------------------Clean air intake.*
12 volt polarity reversed------------------------Correct polarity*
Motor running slow------------------------------Check voltage first. If 12 VDC while running, replace motor.
Exhaust blocked ----------------------------------Clean exhaust.*
Combustion air wheel loose ------------------Reposition and tighten.
Sail switch defective or wire off --------------Reconnect wire or replace.
Limit switch defective or wire off ------------Reconnect wire or replace.
Edge connector on circuit board dirty ------Clean with pencil eraser*
Circuit Board defective --------------------------Clean plug contacts. If still defective, replace. (check on board tester when possible).
Gas valve defective ------------------------------Replace valve or valve coil, depending on problem encountered.
Main burner orifice blocked--------------------Clean main burner orifice or replace.
High tension lead wire defective--------------Replace wire
Electrode out of adjustment ------------------Adjust electrode (take care not to damage porcelain).
Electrode defective ------------------------------Replace
Obstructed burner head ------------------------Clean burner head*


2007 RAM 3500 QC LB SRW 5.9L CTD 48re 4:10 4K in bed 'quiet genny'
2007 HitchHiker II 32.5 UKTG 2000W Xantex Inverter
Hit the Road Debt Free & Clear April '07
Came off the road still Debt Free & Clear Jan. '14


This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Atwood 8531-iv dclp furnace won't fire
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS