RV.Net Open Roads Forum: Class C Motorhomes: HELP! SLide won't slide

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class C Motorhomes

Open Roads Forum  >  Class C Motorhomes

 > HELP! SLide won't slide

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
Linda1195

Virginia

New Member

Joined: 06/23/2005

View Profile


Offline
Posted: 07/01/05 09:21pm Link  |  Print  |  Notify Moderator

OK....this hasn't been a good day. BUT, for now, we have gotten this brand new r.v. home and the slide won't slide out. We push the button and nothing happens. What could we not be doing? HELPPPPPPPPPP

LINDA


In HIS service
Linda">

GotSalt

GA

Senior Member

Joined: 10/22/2003

View Profile


Offline
Posted: 07/01/05 09:33pm Link  |  Print  |  Notify Moderator

You must set the emergency brake before it will work. This is a safety feature to make sure it will not open while you are traveling down the road.


"> 2000 Leak Prone Winnebago 31C
Towing a 1994 Mazda B4000 with a
Remco Drive Shaft Disconect and
a Demco Aluminator Tow Bar
with a Brake Buddy Vantage
(Looking for my lost shaker of salt)


Eycom

32043

Senior Member

Joined: 09/12/2004

View Profile



Posted: 07/01/05 09:34pm Link  |  Print  |  Notify Moderator

If nothing happens and no noise, you may have a loose wire or the brake is off.


RVn Full-time


Novi

Southern Ontario, Canada

Full Member

Joined: 07/16/2003

View Profile


Offline
Posted: 07/01/05 09:38pm Link  |  Print  |  Notify Moderator

Whenever we have had trouble with a new RV it is usually the user, me. We have had 3 MH's over the years and you think you know how they work, wrong. There is always a learning curve whenever you change RVs. So, be patient, read your manuals and walk yourself thru it slowly. If it is new, and if it was working, it is probably the user. Good Luck.

tonigil

Whitehouse Station, New Jersey, USA

Senior Member

Joined: 07/16/2003

View Profile


Offline
Posted: 07/01/05 10:05pm Link  |  Print  |  Notify Moderator

Mine won't work if I have the engine running. Which is on mostly all MHs. I couldn't understand why my slide didn't work either. I kept the engine running for the AC until I turned on the house AC. But, while I was back there, I figured I would open the slide. Nothing happened. This was NOT my first MH either. Just wasn't thinking before I got upset. And YES, the brake. Sometimes it is that simple. But in our haste, we sometimes forget. I hope for your sake that is all it is. I hope that you don't have to go through anything but your manual. Lots of luck.
And Happy Trails. Toni


May you always have
Love to Share, Health to Spare, and Friends that Care!
My Web site

TC285

San Jose, California

Senior Member

Joined: 05/30/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/05 10:52pm Link  |  Print  |  Notify Moderator

That happened to us on our first trip, the fuse for the slide had blown. It took us awhile to figure that out, but when we replaced it everything was fine. That was three years ago and it has worked fine ever since.


Ted and Claire
San Jose, Ca

2001 National "Sea View" Class A V-10



RHR

Tecumseh, Kansas

Senior Member

Joined: 02/09/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/05 11:01pm Link  |  Print  |  Notify Moderator

I would phone who ever I bought it from and ask. I'm sure they would tell you what to check. Just a thought.

HiTech

Texas

Senior Member

Joined: 03/22/2002

View Profile


Offline
Posted: 07/02/05 02:10pm Link  |  Print  |  Notify Moderator

I always want to start the engine to boost up the 12V but mine won't run with the keys even in the run position. Gotta start the genset if I need a little boost.

Linda1195

Virginia

New Member

Joined: 06/23/2005

View Profile


Offline
Posted: 07/02/05 07:20pm Link  |  Print  |  Notify Moderator

And the winner is...........
gotsalt!

I was so upset by the whole day I couldn't think. We set the emergency brake and out she came.

THANKS YOU GUYS!

Linda

GotSalt

GA

Senior Member

Joined: 10/22/2003

View Profile


Offline
Posted: 07/02/05 07:31pm Link  |  Print  |  Notify Moderator

Another satisfied customer! [emoticon]
I'm glad that is all that was wrong with it. Even us old timers make that mistake from time to time.
Happy camping!

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class C Motorhomes

 > HELP! SLide won't slide
Search:   Advanced Search

Search only in Class C Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2018 CWI, Inc. © 2018 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS