RV.Net Open Roads Forum: Truck Campers: Dometic..cools on Elec but not on propane

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Truck Campers

Open Roads Forum  >  Truck Campers

 > Dometic..cools on Elec but not on propane

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
Sponsored By:
Rick Jones

Colorado

New Member

Joined: 07/16/2007

View Profile


Offline
Posted: 10/12/10 08:14pm Link  |  Print  |  Notify Moderator

I have a somewhat similar problem with my Jayco slide-in truck camper. My Dometic frig will cool down really well on electricity but will not cool on propane. I live 45 miles SW of Denver and have not had it checked this season and do not have mobile repair in this area.
Any thoughts or opinions would be appreciated.

Home Skillet

Pearland Texas

Senior Member

Joined: 10/21/2004

View Profile


Offline
Posted: 10/12/10 08:27pm Link  |  Print  |  Notify Moderator

I would pull the cover off and see if the burner is igniting.
A lot of times bugs will build nests inside the burner tube,disrupting the proper flow of gas.


2005 Gulf Stream Conquest 31ft
BigFoot Levelers,SmarTire,Bilstein Shocks,Trans temp guage,Lowrace iWAY

Alpenliter

Fulltimer: Wherever we are!

Senior Member

Joined: 04/10/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 10/12/10 09:44pm Link  |  Print  |  Notify Moderator

Welcome to the forum Rick. Good news is, it's probably not a serious problem. Have you been running propane on the other appliances yet? If not, there is stale air/propane in the lines and you need to purge that out before trying to get the refer to light. Try running the stove first and getting the propane flowing in the lines. Next, take the air/burner mixing tube off and make sure it is clear of bugs and spider webs. Make sure you replace exactly as it was. Finally, if nothing is working yet, remove the orifice and soak it in acetone and blow it out with compressed air or use a toothpick (not anything metal) to clear any obstructions. And finally, a good investment would be Bob Livingstons book of RV Repair & Maintenance Manual. Good luck and again, welcome to the forum.


My first Wife Linda, 45+years 2004 F-450 CC, DRW 6.0 Classy Chassis Upgrade Bulletproof Diesel upgrades 1997 33' Alpenlite 400 Watts Solar Lifetime Good Sam Member #39644174 Escapees SKP#89882 Vietnam Vet '67-'68 [

Note: Due to invalid formatting, all formatting has been ignored.


Rick Jones

Colorado

New Member

Joined: 07/16/2007

View Profile


Offline
Posted: 10/13/10 12:07pm Link  |  Print  |  Notify Moderator

Thank you, joerg....I appreciate your thoughts and will pursue them. The unit is clean and no visible damage and will ignite and stay lit so will try to locate and check the thermocouple. Will also google "dinosaur board" and review to see if this could be a possibility--thx again. rick

kcabpilot

CA

Senior Member

Joined: 04/07/2008

View Profile



Posted: 10/13/10 01:00am Link  |  Print  |  Notify Moderator

Rick

Here's a good troubleshooting manual - domser.pdf

If it's an older RM2611 unit like I have you may be best served by purchasing a dinosaur board Mine took the Micro P-711 and has been working flawlessly ever since.

good luck


1994 Lance 990 on 1997 F350 PSD Dually "Rhino Haunches"

joerg68

Ueberherrn, Germany

Senior Member

Joined: 02/27/2009

View Profile


Offline
Posted: 10/13/10 04:51am Link  |  Print  |  Notify Moderator

From simple and cheap to more complicated and expensive:

1) Check for visible damage or foreign objects

2) Are the burner and the exhaust clean (remove cover to access burner)

3) Is LPG delivered to the burner? Have someone switch on from inside and check whether the flame ignites. Is the ignition spark triggered? You can also try to light the flame with a lighter.

Does the flame light automatically, but goes out after a while?

4) Check thermocouple: The thermocouple senses the heat of the flame and switches a solenoid which delivers LPG to the burner. If no flame is present, the solenoid is closed after some time to prevent a gas leak. If the thermocouple doesn't work properly, the flame may ignite, but not stay lit.

If no flame ignites (even with a lighter / match during startup), then there is probably no LPG delivered and you need to check the gas supply line.

If none of this works...

5) Many people (like myself) have had good success with replacing the control board with the one from dinosaur. Just google "dinosaur board". It seems to be a common problem with these fridges. It is not a very complicated DIY job.

Typically, when the board is shot, the burner lights fine and stays on for some time (up to 20 minutes in my case), then it shuts down and the check light goes on on the control panel. Dometic also sells a replicement wiring harness that is supposed to fix the issue. I have not tried that, as I had found many comments that said the dinosaur board fisxed their issue, as mine did.

The board in question is behind a black rectangular cover on the left hand side when you remove the outside refrigerator cover.

Hope this helps,
Joerg


2008 Chevy Silverado 2500 HD + 2011 Outfitter Apex 8


bigfootford

Fair Oaks, California

Senior Member

Joined: 12/03/2002

View Profile



Good Sam RV Club Member


Posted: 10/14/10 12:06pm Link  |  Print  |  Notify Moderator

Rick Jones wrote:

Thanks, guys...this unit is pretty old--it's a Dometic RM 2310 and I checked the dinosaur board and they didn't have this model listed so not sure what to do.
Checked the burner tube hoping to find obstruction to no avail...oh well, back to the drawing board.


Rick, your fridge does not have a control board...You have one of the best fridges there are!!!! It does not rely on 12vdc to operate on LP.

All it does is control the flame for cooling. There is always a flame once you have ignited it.

If it cools ok on 12 and or 120vac the cooling unit is ok. Thus you probably have a bad thermocouple, burner is obstructed or lastly the burner valve could be defective.
It is a very simple system.

Here is a link to the manual for your fridge:Rm2310 from Bryantrv.com

Here's a link to his website:

bryantrv

Keep us posted.

Jim

* This post was edited 10/14/10 12:39pm by bigfootford *


2000 2500 9.6 Bigfoot,94 F250, Vision 19.5, Mich 245/70XDS2's, Bilstein shocks, air bags/pump, EU2000, PD 9260,Lifeline 100ah, 200W. solar, Morningstar Sunsaver 15A/ display panel, Trimetric, Delorme/laptop, Holux gps rec,led lights, Wave-3 heat.


bigfootford

Fair Oaks, California

Senior Member

Joined: 12/03/2002

View Profile



Good Sam RV Club Member


Posted: 10/14/10 12:21pm Link  |  Print  |  Notify Moderator

Here's a little more, great diagram of your system:



Here's a great link to rvmobile's tech help with your gas system:

You will probably have a piezo igniter instead of an electric igniter. This is not your problem, you do get a flame.

Rvmobile Dometic Manual Refer Gas Control

Thermostat control operation:

Rvmobile Tstat theory



We need to give thanks to these two guys that provide free info like this....
Bryantsrv and Rvmobile....Thanks guys!!!

Support them when you can by getting your parts from them.
Jim

* This post was edited 10/14/10 12:29pm by bigfootford *

belairbrian

Alabama

Senior Member

Joined: 04/18/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 10/13/10 12:10pm Link  |  Print  |  Notify Moderator

Had the same problem. Stupid mud dauber nest in the burner tube.

Red arrow points to where falmes were coming out, blue to the burnt wiring.




TV 2003 Chevy 3500 Crew Cab Dually w Duramax/Allison
2005 Keystone Cougar 314 EFS
Reese 16K Slider Hitch, Prodigy BC, Delorme GPS
USAF Retired


Rick Jones

Colorado

New Member

Joined: 07/16/2007

View Profile


Offline
Posted: 10/14/10 10:59am Link  |  Print  |  Notify Moderator

Thanks, guys...this unit is pretty old--it's a Dometic RM 2310 and I checked the dinosaur board and they didn't have this model listed so not sure what to do.
Checked the burner tube hoping to find obstruction to no avail...oh well, back to the drawing board.

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Truck Campers

 > Dometic..cools on Elec but not on propane
Search:   Advanced Search

Search only in Truck Campers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS