RV.Net Open Roads Forum: Truck Campers: lance strut mount fails after one year

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Truck Campers

Open Roads Forum  >  Truck Campers

 > lance strut mount fails after one year

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 6  
Next
Sponsored By:
saileyboy

Wisconsin

Full Member

Joined: 08/25/2005

View Profile


Offline
Posted: 07/27/06 11:49am Link  |  Print  |  Notify Moderator

Just installed the Lance struts last spring, and now the two mounts on the truck are complete trouble.
The mount on the driver side: the little plunger is stuck in, and if I tap on the unit, it will come out, but with no spring tension. It is shot, and I don't see way of fixing this, as it is a closed system.
The passenger side has a little spring tension, but can get stuck in also. Thus the spring washer got lost. Why can't Lance supply a couple extra of these when you buy this $350.00+ system. Can you imagine going through the trouble of visiting the dealer and hoping he would even care to help you with this?

One strut came off on the passenger side a week ago. Now I wiggle these and check that the plungers are out. Came off on the freeway. And this is the side with a little spring pressure left on the mount plunger.

Not happy. Not happy at all with these struts.
If there is a fix, please let me know
thanks

Not4Hwy

Huntsville, Alabama

Full Member

Joined: 12/13/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 07/27/06 11:52am Link  |  Print  |  Notify Moderator

what about drilling out the small port and just using a small carter pin? They wouldn't bounce out on the road. Steve


formally known as: Steve Curet

Lowgroundpressure

north west of dallas

Senior Member

Joined: 01/27/2006

View Profile


Offline
Posted: 07/27/06 12:02pm Link  |  Print  |  Notify Moderator

I don't know, if they are that bad, will they give you your money back.

Do they help when they are working??

When I bought my Lance they mentioned them and I thought they were kidding. Struts from the camper to the truck. If I had to buy them to run the camper, deal was off.

Just my opinion

jjohnson1179

Girdletree, Maryland

Senior Member

Joined: 04/27/2006

View Profile



Posted: 07/27/06 12:52pm Link  |  Print  |  Notify Moderator

Just drill a hole, stick a cotter pin in it and keep them lubed up with white lithium grease. It is a night and day diff. when they are on the truck they made a world of diff. on my rig. they will be on anything i own.


JIMMY JOHNSON
93 Ford F-250 V8 5.8
Sold my tc and got a TT
1987 LANCE 980 11.3

TRUCK CAMPER MAGAZINE

FEET IN THE SAND COLD BEER IN MY HAND


saileyboy

Wisconsin

Full Member

Joined: 08/25/2005

View Profile


Offline
Posted: 07/27/06 04:50pm Link  |  Print  |  Notify Moderator

I would thing to drill these out, you would have to remove them. I can't imagine drilling out a hardened pin while on the truck, as because of this little POS I have four new scratches on the 1/4panel already.

To take them off I would have to take off all that plastic and junk.

If you did drill these out, please let me know what you did with a bit more info
thanks

Eycom

32043

Senior Member

Joined: 09/12/2004

View Profile



Posted: 07/27/06 04:58pm Link  |  Print  |  Notify Moderator

I had a pin fail after 3 months. The dealer replaced it. When it goes again, it'll be carter pin time. Be sure to check the screws holding the strut bracket to the camper. They will work loose over time.


RVn Full-time


Bumpy

Cape Cod

Senior Member

Joined: 03/12/2006

View Profile


Offline
Posted: 07/27/06 06:20pm Link  |  Print  |  Notify Moderator

They are not needed in my opinion. Do away with them and end the fiasco. Your mileage may vary.

DmaxCamper

Brush Prarie, Washington

Senior Member

Joined: 08/23/2004

View Profile


Offline
Posted: 07/27/06 07:08pm Link  |  Print  |  Notify Moderator

I made a habit of applying a drop of oil every once in a while, we get a lot of rain here and I didn't want any rust issues. Two years now and not one problem, I also would NOT go with out them on my rig after having them and experiencing the ride difference.


2000 Arctic Fox 1150// '04.5 CHEVROLET 3500 SRW CC LB 4X4 D'MAX/ALLI.
FIRESTONE BAGS w/in cab controller and air fill tank kit
RANCHO 9000's // LANCE brand cab over struts/stabilizers
Happijac tie downs w/guides.
Goodyear 275/65-20's rated at #3750 ea.


sleepy

Oak Ridge,Tennessee

Senior Member

Joined: 04/07/2003

View Profile



Posted: 07/27/06 08:14pm Link  |  Print  |  Notify Moderator

I assume that you have asked lance for replacements at their 800 number?

Mine were damaged in a wreck.. the only trouble that I ever had. Lance did the insurance repairs, they replaced the dampers and told me that they can rebuild the old ones.

I also lubricate the little detent balls... they get dirty from dirt, 60 mph bug juice, rain... etc.

I try to keep every thing clean and waxed or lubed.... it's a lot of investment. I even wash the trucks engine and wax the wheel wells.


2003 Lance 1161,/slideout/AGM batteries/255W Solar/propane generator/Sat dish/2 Fantastic Fans/AC/winter pkg
AirFoil, Trimetric, LED lights, Platcat vent heat

2003GMC K3500 LT/Crewcab/duramax diesel/allison/dually/4x4/OnStar/front reciever mounted spare

S'mores

USA

Senior Member

Joined: 04/23/2005

View Profile


Offline
Posted: 07/27/06 08:48pm Link  |  Print  |  Notify Moderator

Mine broke on the first trip. Lance said not to use them on rough roads or off-roading....which kind of defeats the whole purpose of having them. It also seemed like the camper structure was absorbing much of the stress, not necessarily the shock. Good riddance!

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Page of 6  
Next

Open Roads Forum  >  Truck Campers

 > lance strut mount fails after one year
Search:   Advanced Search

Search only in Truck Campers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS