RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'Arvie1' found 6 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: macerator stopped working

Hello Fullmoon Sorry for the delay in responding. I just winterized the RT this week and wanted to check out the new macerator to see that it operated as it should, before I tucked her in for the winter. As the tank had not been used since the new macerator was installed, I half filled both the black and grey tanks with water, and then tried it out. Wow...what a difference,like a fire hose now... and both valves worked as the should!! Costly repair, but definitely worth it. I guess it's like worn brakes on your car....you don't realize how bad they were, until they are replaced! After emptying the water from the sanitary tanks, running antifreeze throughout the entire plumbing system, including the macerator, I was a happy man!
Arvie1 11/10/21 06:02pm Class B - Camping Van Conversions
RE: macerator stopped working

Hello fullmooon, I finally resorted to raising the van onto three layers of link levellers on the passenger side and got under the RT in my driveway. With a 3.5 gallon bucket under the 3" ABS cleanout, I loosened the plug until the black tank started draining into the bucket. After many trips to empty the bucket down the toilet, the tanks were finally empty. This past Tuesday, we finally had the macerator replaced. The gray slide valve however also had to be replaced as apparently the seal had dislodged some time ago and damaged the valve beyond repair. It was all internal as there was no leaking. The black valve cable was fixed, and now we are fully operational with the valves now working independently! Expensive, but good news.
Arvie1 10/14/21 08:35am Class B - Camping Van Conversions
RE: macerator stopped working

Hello jjrbus, Thanks for the link. It is definitely a great idea. My valve handles seen to work easily when pulling and pushing back in, but do not seem to actually affect any change. I cannot separate the grey from the black and they empty simultaneously. Each valve connects to a cable (similar to bicycle brakes)and I wonder if this is the source of the problem if there is too much slack or movement in the cable. Thanks again for you input.
Arvie1 09/30/21 08:13am Class B - Camping Van Conversions
RE: macerator stopped working

Hello jjrbus, Thank you for your reply and link. Definitely interesting. Our RT does have the grey and black slide valve handles, but they too do not function as they should anymore. I will have that fixed as well. Here's an UPDATE on how I got the tanks emptied this weekend. I put the van on three layers of Link Levellers on the passenger side only of the van. This allowed me to gain access to the macerator and plumbing. There is a 3 inch ABS clean out/drain with a plug. I placed a 3 1/2 gallon pail under the plug and then loosened the plug until fluid from both tanks started to drain into the pail being careful not to unscrew the plug entirely! I did this several times and emptied the pails down the toilet. I then used my black tank spray wand and gave the tank another cleaning and then emptied it again. For the first time in a long time, the tank actually registered green on the instrument panel!! SUCCESS ! And no adverse impact to the environment :)
Arvie1 09/27/21 08:57am Class B - Camping Van Conversions
RE: macerator stopped working

Thank you jdc1, Jim&Carolyn, MitchF150 and bdpreece, I appreciate your comments and have booked the earliest appointment for replacement on Oct 12th. We only turned 50,000 miles on this last trip and try to keep our RT in the best condition we can...even no tissue in the black tank! This will be my second replacement macerator! A little disappointing for so little use, but maybe that is part of the problem. Hopefully I can figure out some way to empty the tank before taking it to the RV Centre so they don't have to endure that unpleasantry! Thanks again for your input.
Arvie1 09/24/21 09:52am Class B - Camping Van Conversions
macerator stopped working

Hello all, Just returned from short trip in our 07/08 RT190P and experienced macerator problems. The volume or force of the flow seemed less, and the macerator motor seemed less noisy as well. Clearly it took longer to empty but was still working. Tried to empty the holding tanks after getting home but this time the macerator was not pumping at all, despite hearing its motor trying to work. I have tried churning the contents of the tank with my black tank water spray cleaning wand, as well as back washing through the discharge hose. Unfortunately neither has helped. Now I have a full black tank (mostly water, no solids) and no way to empty it! Winterizing will be a problem. Does anyone have any ideas on the problem and/or solutions? Many thanks, Arvie1
Arvie1 09/23/21 10:12am Class B - Camping Van Conversions
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.