RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'Belting 1313' found 2 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Unusual tire wear

I agree with all that has been said it most likely is an alignment issue. However you did say something interesting about the front end being light. It is possible that if you are running to light on the front it will cause odd tire wear.
Belting 1313 03/26/20 06:40am Class A Motorhomes
RE: Obtaining permits while in Mexico

This actually happened to me also. A drove from Oregon to Salamanca Mexico crossing at Santa Teresa by Juarez. Crossed early on a Sunday morning and must have been half asleep because it took me about 4 hours south before I realized that I didn't have any documentation to show anything. No trip permit no stamp in my passport nothing. Called the mexican consulate and told me that since I was scheduled to fly out to see immigration at the airport. 2 weeks after crossing and at the Guadalajara airport I went to immigration and they took care of everything it did cost me a fine of like 1,500 pesos but it all got taken care of. You might try calling the airport and see if they can help you. Hope it all works out.
Belting 1313 01/29/20 02:20pm RVing in Mexico and South America
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.