RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'DavidRue' found 3 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Coachmen Leprechaun fresh water tank

Thanks for replies. I am sure I put hose into correct fill valve to fill fresh tank. It took a long time to fill fresh tank, and monitor showed it full. Thanks so much but I'm stumped (I've only used black water flush valve once and it makes a distinct rushing water sound, so I am sure I was filling fresh tank. I was nearby the whole time). Thanks! Dave
DavidRue 07/29/20 02:37pm Tech Issues
Coachmen Leprechaun fresh water tank

This topic has been moved to another forum. You can read it here: 30117380
DavidRue 07/28/20 08:37am Forum Posting Help and Support
Coachmen Leprechaun fresh water tank

I have a 2018 Coachmen Leoprechaun 21QB. Have taken many trips. Recently I filled my fresh water tank, waiting in the driveway for it to fill. When I heard the overflow water running onto the driveway, I looked underneath and it seem water was also splashing out of somewhere right by the overflow drain tube. Shut off the water and didn't think much of it. I did not use the presurre regulator like I usually do. Later in the day while on our trip I discovered that the water tank was completely empty. (drain valves were shut tight) Also, the black water tank that was emply when I left was now full of water. As I drove to destination, I spent the whole time worrying about did I split my water tank of bust a pipe somewhere? I was so worried about a major repair needed. Arrived destination that day, and immediately went to work diagnosing. I filled water tank with a hose, until the overflow started running onto the ground and shut off hose. NO leaks anywhere, all normal. For 4 days now I have used the fresh water system (and I had drained black tank). Water pump on full time during the 4 days. Only thing I thought was odd is that when I filled tank at my destination, when it began to overflow, the overflow ran for a while onto ground after hose shut off- about 3-5 gallons flowed out. But all seems normal now. All plumbing, pump, heater, etc. work fine. SO, what on earth happened at beginning of trip when fresh tank emptied from full, and black tank went from empty to full of water, and all seems perfect now??? Thank Dave
DavidRue 07/28/20 08:37am Tech Issues
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.