RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'kharrell1972' found 5 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: 1997 Holiday rambler Endeavor LE Ford 460

Thanks for the replies… I just went and picked it up today to take it the exhaust shop. Drove it without any issues. It does feel like there is not a lot of power but I figured that is because it is a gasser and is so big. I don’t expect it to be like a hot rod but figure it should have more power than it does. As it is, I wouldn't trust trying to drive through even the smallest of mountains! It has sat for a week since I parked it so leads me to believe the excessive exhaust back pressure is causing the lack of power and maybe something to heat up which eventually causes it to lose power. I am told braking is affected when the exhaust back pressure is excessive.
kharrell1972 06/18/22 04:40pm Class A Motorhomes
RE: 1997 Holiday rambler Endeavor LE Ford 460

Everything has been went through. That is what I am saying. All new Belts, hoses, oil, filters, fuel injectors, fuel pump, plugs, wires all new brakes, calipers and rotors, AC units checked, generator runs like a top etc…. The mobile mechanic says the exhaust is plugged. I have read that the 95-97 F53 chassis with the Ford 460 did not come with catalytic converter. I Realize it has extremely low miles but this thing is cherry! Just wondering if anyone had any dealings with exhaust or catalytic converter issues if there are any on this model.
kharrell1972 06/14/22 06:12pm Class A Motorhomes
RE: 1997 Holiday rambler Endeavor LE Ford 460

It had not sat it was being used. It has all new belts fuel filters injectors plugs wires etc.. ran good until the issue after we stopped.
kharrell1972 06/14/22 09:30am Class A Motorhomes
1997 Holiday rambler Endeavor LE Ford 460

This topic has been moved to another forum. You can read it here: 30341932
kharrell1972 06/14/22 06:53am Forum Posting Help and Support
1997 Holiday rambler Endeavor LE Ford 460

Just got a good deal (or so I thought) on this coach. On the way home, we stopped at a rest area for a few minutes. Once we stated back on the road the coach started hesitating really bad and would not get over 40. I managed to get a hold of a road side mechanic and actually got the unit to him. He says the exhaust is plugged up as he checked the back pressure. Likely the catalytic converter. However from what I have read that year f53 chassis doest have a cc. The unit rums absolutely fine unless under power and there is just nothing there. The brakes are pretty hard to get it to stop as well. Indicating an exhaust issue. If the there is is no cc on it what else could be causing a plug. The unit only has 15,000 on it and runs great! No back fire no jumping or missing just no power. Any help is greatly appreciated!
kharrell1972 06/14/22 06:53am Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.