RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'kode9' found 1 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
No heat / Furnace not working

Hi. I bought in August a Grand Design 297QB brand new and while I did test everything there - on the RV lot - and then, nowadays when temperatures start to drop, the heater is not working. It did work for a couple of hours back in September, but now. Nothing. Nada. NONE. And all I did then was to just to increase the temperature of the thermostat from 75 to 82( or something like that ) and heater would work. Now if I do the same, the only thing that comes out is cold air. The thermostat is a Coleman-Mack. Must mention that I am complete noobie when it comes to RV/Traver trailers and so on. Thank you.
kode9 11/12/21 12:45pm Travel Trailers
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.