RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'markusbrown' found 1 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: One jack not functioning AF811

I just had the same problem with my AF811. My jacks are Reico Titan. I called their service support number and they were very helpful. The control panel is located under the sink and they had me switch the two wires for that jack, which were the bottom set with the two right above them. It worked then. The upshot is that the control panel circuit for that jack was defective. I ordered a new control panel which was $500. They had rebuilt ones that I don’t remember the price. They also said that they don’t repair them, they have an outside company do it. Mark (This is the first post I made to this site)
markusbrown 04/16/21 05:14pm Truck Campers
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.