RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'pcdj64' found 5 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Suburban Furnace No Delay

The startup is functioning as it should. As for the shut down, it may be that you have not allowed it to get hot enough for the fan to stay on when shutting the unit down. Try letting it run for 10-15 minutes, then turn it off. At that point, it should be hot enough that the fan will continue to run for a short time. Thank you, i will give that a try.
pcdj64 11/12/19 02:57pm Tech Issues
RE: Suburban Furnace No Delay

Thank you for all of the replies and the details on it. It does do exactly as you described, i only had to reset the thermostat once when there was still air in the lines from the propane being off. the only thing it does not do is run for any length of time if you shut off the thermostat, it stops immediately. I never let it run long enough to really get hot, i just got the RV and was pretty much testing everything. I had it on for maybe 7 minutes to make sure the air warmed up and there was hot exhaust outside. I was off on the year, it is a 1984 not a 1987, my friend's furnace just like it is a 1987, i scavenged parts out of his because he is junking the RV and his furnace has a blown motor. I timed everything on startup to make sure there was a delay after the fan starts up, i don't know a lot about these furnaces and don't want a fire from it.
pcdj64 11/07/19 02:06pm Tech Issues
RE: Suburban Furnace No Delay

I don't know model, 30,000 BTU suburban 1987. On startup fan starts and a little time passes and then gas flows and ignition fires. If i turn off thermostat it shuts down fast. It is original 1987 old school non digital thermostat. It has never been modified, i compared it to another identical furnace and everything is tbe same, there isn't a time delay relay but there is a large gold relay with a lot of wires.
pcdj64 11/07/19 09:47am Tech Issues
Suburban Furnace No Delay

I don't know if this is anything to be concerned about. My Suburban furnace has no delay starting or stopping. It blows hot air and can be adjusted with the thermostat but it always is immediate fan starting up and the whole thing immediately stops if you turn the thermostat down or off. I got the RV used and there was never a delay with the furnace.
pcdj64 11/07/19 04:48am Tech Issues
New from CT with Hybrid

Hello, i am new from CT. I purchased a 2006 Starcraft Hybrid 18RB for $500 and fixed it up. It had a rotted floor and one bad spot on ceiling. I redid the floor and put a new vinyl sheet on the ceiling, it currently has no roof leaks and is is pretty nice shape. I think i got a great deal on it and hope to get a lot of use out of it. I have a question. Can i put a motorcycle carrier and a 483 pound Kawasaki motorcycle on it's rear receiver? It looks like it has a good strong weld.
pcdj64 10/12/19 09:59am Hybrid Travel Trailers
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS