RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'ricelake922' found 1 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
White smoke from exhaust

Hello. I have a 1986 Monaco Dynasty. I was 3 hours into a trip when I noticed while smoke coming from exhaust. This smoke only occurs when accelerating. The coolant is full, the transmission fluid is topped off and the oil is at a good level. I changed the oil 2 months ago and had the oil analyzed with out issue. I changed the fuel filters in September of last year prior to storage. Once I diagnosed the issue, I continued to drive and about 5 minutes into driving the white smoke from exhaust ceased. However when I arrived at my destination and used brake white smoke appeared again from exhaust and stopped again when driving to my spot at the park I was staying at. I would appreciate any thoughts, ideas, suggestions etc. Thank you in advance.
ricelake922 08/20/19 05:32am Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS