RV.Net Open Roads Forum: Search

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'troy t' found 6 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Slide out issue

Just the bulb seal looks easy but on the top and one side I need to replace the wiper seal also. Fun stuff. Makes my memories of the old hybrid much fonder!
troy t 03/28/21 08:34pm Travel Trailers
RE: Slide out issue

Did a little You-tubing and I do have the Schwintek system. Grabbed a ladder and went up to lok at the top where the motor is and realized I need to replace the seal across the top. Doesn't look like a horrible job, has anybody done that?
troy t 03/28/21 03:09pm Travel Trailers
RE: Slide out issue

So I installed the battery and that solved the problems. Slide went out and in like it’s supposed to I guess. My problem as far as maintenance is I have no access anywhere? The kitchen and a couch are in the slide and I see no access to the mechanism without some disassembly. From the exterior of the camper on the bottom of the slide I can see where it rolls out on 5 small rollers. Then there’s 2 tracks on each side, one at the bottom and one at the top. Again, first camper with a slide for me so sorry for the dumb questions.
troy t 03/28/21 02:27pm Travel Trailers
RE: Slide out issue

OK, I've got the battery on the charger and will pop it in yet this afternoon. Somebody mentioned greasing it all. How do I do that, can't even see the mechanism.
troy t 03/28/21 12:32pm Travel Trailers
RE: Slide out issue

OK, just want to make a quick update. After jiggling it some I now have the rear moving out about 3-4" while front moves out 6-7" and then it all stops. Retracts in just fine but still won't fully extend, lots of noise though as it is extending. New to the world of slides so its probably something simple that I don't know so any help would be great.
troy t 03/28/21 11:42am Travel Trailers
Slide out issue

Hi, looking for some help on a trailer. We sold our Hybrid this summer and started looking for a new trailer. We found a 2012 Shasta Revere that we bought over the winter from a private party. Shame on me but we couldn’t see if everything functioned due to it being well below freezing when we bought it. My first challenge is I can’t get the slide to go out. It’s about a 12’ by 18” slide and the one side starts to go out but the other side seems to be stuck. So the front side will move out about 2” while the rear side won’t move at all. Seems to be a whine from the motor near the front, is there a motor at the rear also? Thanks I’m advance. I checked fuses, every thing seems fine. I do not have the battery installed, just plugged in right now.
troy t 03/28/21 11:14am Travel Trailers
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.