RV.Net Open Roads Forum: Class A Motorhomes: Breakdown Information

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > Breakdown Information

Reply to Topic  |  Subscribe  |  Print Page  |  Post New Topic  | 
Page of 82  
Prev
Sponsored By:
angler

WI

Senior Member

Joined: 08/21/2002

View Profile



Posted: 02/01/19 05:48pm Link  |  Quote  |  Print  |  Notify Moderator

RV particulars 2002 Allegro Bay
Driveline Workhorse 24K Allison 8.1
Miles:83000
Year:2002
Break Down Description: No start
Symptoms: No Start in front of my house ready to travel. Started 5 times the same day.
Effect: No Cranking just silence.
Cause: Starter relay female connectors in the fuse box are worn.
Outcome: Call roadside since it was so cold the hood wouldn't open. 986 dollar tow bill. Thank you roadside assitance.
Had to bend pins on the starter relay for better connection. until connectors in fuse box can be replaced.


2002 Tiffin Allegro Bay 35DB
Workhorse 8.1

Reply to Topic  |  Subscribe  |  Print Page  |  Post New Topic  | 
Page of 82  
Prev

Open Roads Forum  >  Class A Motorhomes  >  All

 > Breakdown Information
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS