RV.Net Open Roads Forum: Tow Vehicles: "Service trailer brake system" on 2016 GMC

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tow Vehicles

Open Roads Forum  >  Tow Vehicles

 > "Service trailer brake system" on 2016 GMC

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
Sponsored By:
jabres

Ohio

Full Member

Joined: 06/14/2016

View Profile


Offline
Posted: 01/15/19 02:10pm Link  |  Quote  |  Print  |  Notify Moderator

Have a 2016 GMC 3500, 6.0 gas job with 57K miles.
Constantly now my computer screen beeps "Service Trailer Brake System", even when no trailer is hooked to truck..
took to my local trailer guy, he checked my plug port where trailer lights plug in, and we checked all fuses. he said neither is the problem.
he says its either the factory built trailer brake controller that was built in dash, or the "Module" that is up under the spare tire. Anyone ever have this issue?
He said it would be a guessing game for him. I hate to take it to the stealership for diagnosis though....

ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile


Offline
Posted: 01/15/19 02:15pm Link  |  Quote  |  Print  |  Notify Moderator

I would take apart the connectors behind the bumper and make sure none have moisture in them. Assuming there isn't a failure with the brake controller, it's seeing a connection to the brake actuating wire at the trailer connector. That could be moisture, rodent damage, etc.


Scott, Grace and Wesly
2003 Dodge 3500 4x4, 6 speed Cummins.
2018 Silver Fox 32A.
H0NDA eu2000i

LIKE2BUILD

Decatur

Senior Member

Joined: 09/30/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 01/15/19 03:24pm Link  |  Quote  |  Print  |  Notify Moderator

Are you not under warranty? If you are I'd take it to the dealer and let them sort out the issue.


2012 Sandpiper 32QBBS
'14 Ram 2500 | Crew Cab Long Bed| 4X4 | Cummins TurboDiesel
Curt Q20 with Ram 5th Wheel Prep
2000 Crownline 205BR
1997 Ranger Comanche 461VS
'96 Polaris SLT780 PWC
'94 Polaris SLT750 PWC
3 Wonderful Sons (18, 11, & 10)
1 forgiving wife!!!


ksss

Eastern Idaho

Senior Member

Joined: 02/19/2011

View Profile


Offline
Posted: 01/15/19 04:01pm Link  |  Quote  |  Print  |  Notify Moderator

My 08 was doing that this Winter first time I had seen it before. Moisture or issue at the rear plug is cause.


2006 GMC 3500 CC 4X4 DRW D/A
2013 Fuzion 342
2011 RZR Desert Tan
2012 Sea Doo GTX 155
2018 Chevy 3500HD CC LB SRW 4X4 D/A
2015 Chevy Camaro ZL1

neil57

southern Ontario

Full Member

Joined: 10/08/2012

View Profile


Offline
Posted: 01/15/19 05:13pm Link  |  Quote  |  Print  |  Notify Moderator

Friends truck had same issue, was the ground on the module up by spare tire. It’s not expensive to just replace it.


2009 2500HD Sierra CC DA
2014 Crossroads Cruiser 35ss

jabres

Ohio

Full Member

Joined: 06/14/2016

View Profile


Offline
Posted: 01/15/19 05:37pm Link  |  Quote  |  Print  |  Notify Moderator

Like2build- wish it was, just this year GMC was 3 years 36000 miles, which is kinda a joke.

Fisherman

Angus, Ontario, Canada

Senior Member

Joined: 09/28/2002

View Profile


Offline
Posted: 01/15/19 05:40pm Link  |  Quote  |  Print  |  Notify Moderator

Maybe a bit of road salt corrosion happening causing electrical gremlins to surface.

Beaker

Brevard, NC

Senior Member

Joined: 07/28/2003

View Profile



Good Sam RV Club Member

Offline
Posted: 01/15/19 08:34pm Link  |  Quote  |  Print  |  Notify Moderator

Had that problem on my 08. Controller replaced under warranty.


2008 Silverado 2500HD Duramax
2010 Cruiser 26RK

deltabravo

Spokane, WA

Senior Member

Joined: 09/08/2003

View Profile


Offline
Posted: 01/15/19 08:54pm Link  |  Quote  |  Print  |  Notify Moderator

Pressure transducer failed on my 2009 back in about 2011.


2009 Silverado 3500HD Dually, D/A, CCLB 4x4 (bought new 8/30/09)
2009 Arctic Fox 811 (bought new 11/9/09)
2015 Nash 17k (bought pre-owned 5/23/18)
2008 Haulmark 8.5x20 toy box trailer

jabres

Ohio

Full Member

Joined: 06/14/2016

View Profile


Offline
Posted: 01/26/19 12:26pm Link  |  Quote  |  Print  |  Notify Moderator

Not that anyone cares lol, but I figured I would update this post incase someone searches this in the future.
I ended up trying out the cheapest and easiest part to replace, bascially throwing parts at it, and bam it worked. My factory trailer brake controller was the problem. I had one sent via Amazon, $43 later changed it out and works like new. No more stupid computer telling me to service trailer brake system. I love my GMC's, but kinda crazy the factory brake controller went bad on a 3 year old truck with 57k miles. O well, could be worse

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Tow Vehicles

 > "Service trailer brake system" on 2016 GMC
Search:   Advanced Search

Search only in Tow Vehicles


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS