RV.Net Open Roads Forum: Fifth-Wheels: Brakes are NOT working

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Fifth-Wheels

Open Roads Forum  >  Fifth-Wheels

 > Brakes are NOT working

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
romore

Okanagan valley British Columbia

Senior Member

Joined: 09/18/2010

View Profile


Offline
Posted: 02/06/19 08:18pm Link  |  Quote  |  Print  |  Notify Moderator

I would also look for a loose/corroded connection in the tow vehicle receptacle.

larry barnhart

wenatchee. wa usa

Senior Member

Joined: 03/30/2001

View Profile





Offline
Posted: 02/07/19 09:01am Link  |  Quote  |  Print  |  Notify Moderator

We had the same issue last year with poor braking. The ground was the problem at the trucks plug to connect the trailer . prodigy had movements that had OG on the display. brakes worked but not normal.

chevman


chevman
2001 35 ft avalon alpenlite RK
2005 3500 2wd duramax CC dually
prodigy
easyrider/reese airhitch
trailair center point suspension
JT Strong Arm Stabilizers
KSH 55 inbed fuel tank

scanguage II
TD-EOC
Induction Overhaul Kit
TST tire monitors
FMCA # F479110


remdog*1

Wilmington, De

Full Member

Joined: 02/28/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 02/07/19 10:25am Link  |  Quote  |  Print  |  Notify Moderator

Dont’t forget to check towing fuse under hood of tow vehicle

klr650goldwing

minnesota

Senior Member

Joined: 01/20/2010

View Profile


Offline
Posted: 02/07/19 11:00am Link  |  Quote  |  Print  |  Notify Moderator

Thanks to everyone for trying to help. Turned out it was the controller itself. I installed a new one and we are good to go.


2011 Crossroads Cruiser, CF325CKP
2004 F350, V10, CC, LB, 4X4, 456
2004 Honda Goldwing GL1800
2004 Kawasaki KLR650
1966 Honda 305 Dream

larry barnhart

wenatchee. wa usa

Senior Member

Joined: 03/30/2001

View Profile





Offline
Posted: 02/08/19 07:30am Link  |  Quote  |  Print  |  Notify Moderator

nice to have your new information.

chevman

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Fifth-Wheels

 > Brakes are NOT working
Search:   Advanced Search

Search only in Fifth-Wheels


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS