RV.Net Open Roads Forum: Tech Issues: Electrical issue

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Electrical issue

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
Sponsored By:
gtschulz

Southgate, MI

Senior Member

Joined: 01/05/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 02/21/19 10:56am Link  |  Quote  |  Print  |  Notify Moderator

I have a 2007 Damon Tuscany 4072. I am losing electrical power often, AC will go off, carryout satellite goes off, convection over clock blinks until reset. In other words everything on shore power goes out. However within 5 seconds the power comes back on.
Today i replaced the IOTA ATS and i still have the problem. No circuit breakers trip. I had the electrical pedestal checked all looks good there.

Any ideas of a cause?

Thank you!!!


Deputy Chief/Fire Marshal (retired)

newman fulltimer

louisiana

Senior Member

Joined: 05/19/2012

View Profile



Posted: 02/21/19 11:32am Link  |  Quote  |  Print  |  Notify Moderator

Tighten all wires in your breaker box your power managmant is seeing extra resistance and shutting off then resetting

gtschulz

Southgate, MI

Senior Member

Joined: 01/05/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 02/21/19 01:37pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks for responding. I will do as you suggest.

1492

Arlington, VA

Moderator

Joined: 04/08/2005

View Profile



Posted: 02/24/19 09:41pm Link  |  Quote  |  Print  |  Notify Moderator

Moved from Forum Posting Help and Support

MrWizard

Traveling

Moderator

Joined: 06/27/2004

View Profile



Posted: 02/24/19 09:56pm Link  |  Quote  |  Print  |  Notify Moderator

would these items be on circuits that are also supplied by an inverter

if so do a power reset on the inverter, and check the battery cables and wiring of the inverter


Radiate The Happy
....

Connected using Verizon and AT&T
1997 F53 Bounder 36s


time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 02/24/19 10:29pm Link  |  Quote  |  Print  |  Notify Moderator

I would measure and start monitoring voltage on the main breakers.
Going to be a tough call on where the issue is for just 5 seconds.
Do you have an energy management system that might be shutting down power for low voltage?
I assume you have checked house battery voltage is pretty steady at ~13.5 volts.


2001 F150 SuperCrew
2006 Keystone Springdale 249FWBHLS
675w Solar pictures back up

jjrbus

FT Myers FL

Senior Member

Joined: 07/19/2008

View Profile


Offline
Posted: 02/25/19 04:48am Link  |  Quote  |  Print  |  Notify Moderator

Often overlooked is the shore power pedestal, can be loose or bad connections in it, including bad connection between breaker and buss. Circuit breakers in pedestal are often used as off and on switches, they are not switches, they are circuit breakers and can go bad.

I cringe when I have an intermittent problem, give me a total failure anyday : )

wa8yxm

Wherever I happen to park

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 02/25/19 07:20am Link  |  Quote  |  Print  |  Notify Moderator

newman fulltimer wrote:

Tighten all wires in your breaker box your power managmant is seeing extra resistance and shutting off then resetting


Also check inlet (the place you plug in teh shore cord) outlet (on the rv end of shore cord and any other screws in teh electrical chain.

I'm fond of saying many RVers have a few screws loose.. One of the circuit breakers in my Damon.. 3 1/2 full turns to tighten.. ANd yes. the device it powered worked much better after tightening.


Home is where I park it.
Kenwood TS-2000 housed in a 2005 Damon Intruder 377


gtschulz

Southgate, MI

Senior Member

Joined: 01/05/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 04/14/19 08:01am Link  |  Quote  |  Print  |  Notify Moderator

Here is an update on my electrical issue. The power company checked their equipment from pole to the meter and all was well. That left either the pedestal or my motorhome. After the motorhome was rule out the park management decided to change the breaker that isolated the pedestal. It was an old breaker. After the breaker was replaced the problem stopped. I was not aware that a breaker could cause this type of problem but apparently it can.

time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 04/14/19 08:22am Link  |  Quote  |  Print  |  Notify Moderator

Thanks for the follow up.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Tech Issues

 > Electrical issue
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS