RV.Net Open Roads Forum: General RVing Issues: Water pump

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in General RVing Issues

Open Roads Forum  >  General RVing Issues

 > Water pump

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
Sponsored By:
LOFAT36

Canada

Senior Member

Joined: 08/09/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 05/22/19 04:52pm Link  |  Quote  |  Print  |  Notify Moderator

After 6 months in Arizona, arrived home end of March in Canada. Drained and winterized after getting home. Today I filled the fresh water tank and turned on the pump to fill the hot water tank. Now the pump won’t shut off. I left it off for a hour so but when I turn it back on it still runs. No leaks anywhere. Any ideas ?

rockhillmanor

On the Road

Senior Member

Joined: 12/06/2003

View Profile



Posted: 05/22/19 05:01pm Link  |  Quote  |  Print  |  Notify Moderator

LOFAT36 wrote:

After 6 months in Arizona, arrived home end of March in Canada. Drained and winterized after getting home. Today I filled the fresh water tank and turned on the pump to fill the hot water tank. Now the pump won’t shut off. I left it off for a hour so but when I turn it back on it still runs. No leaks anywhere. Any ideas ?
It means something is open somewhere. Would help to know what type of RV as water inlets differ.

Check your water inlet fill cap on tight and check the screen inside. Check valves can get worn out or just pushed out of position. Push it with your finger to reseat and try again.


We must be willing to get rid of the life we've planned,
so as to have the life that is waiting for us.


LOFAT36

Canada

Senior Member

Joined: 08/09/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 05/22/19 05:25pm Link  |  Quote  |  Print  |  Notify Moderator

rockhillmanor wrote:

LOFAT36 wrote:

After 6 months in Arizona, arrived home end of March in Canada. Drained and winterized after getting home. Today I filled the fresh water tank and turned on the pump to fill the hot water tank. Now the pump won’t shut off. I left it off for a hour so but when I turn it back on it still runs. No leaks anywhere. Any ideas ?
It means something is open somewhere. Would help to know what type of RV as water inlets differ.

Check your water inlet fill cap on tight and check the screen inside. Check valves can get worn out or just pushed out of position. Push it with your finger to reseat and try again.
. 2011 Rockwood TT. Fill cap is on and I never touched any valves when I got home. Is there a reset on the pump ?

pianotuna

Regina, SK, Canada

Senior Member

Joined: 12/18/2004

View Profile


Online
Posted: 05/22/19 05:30pm Link  |  Quote  |  Print  |  Notify Moderator

when you open a tap does water come out?


Regards, Don
My ride is a 28 foot Class C, 256 watts solar, 556 amp hours of AGM in two battery banks 12 volt batteries, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.

LOFAT36

Canada

Senior Member

Joined: 08/09/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 05/22/19 05:33pm Link  |  Quote  |  Print  |  Notify Moderator

Yes.

LOFAT36

Canada

Senior Member

Joined: 08/09/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 05/22/19 05:40pm Link  |  Quote  |  Print  |  Notify Moderator

Yes. I put the hot water tank on gas and when it reached temp and shut down I released the check valve for relief in the tank. Same thing, turned on the pump and it keeps running.

Dutch_12078

Winters south, summers north

Senior Member

Joined: 10/07/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 05/22/19 05:47pm Link  |  Quote  |  Print  |  Notify Moderator

There may have been some water left in the pump that froze and changed the pressure switch adjustment. Check your pump manual for the correct adjusting procedure.


Dutch
2001 GBM Landau 34' Class A
F53 chassis, Triton V10, TST TPMS
Bigfoot Automatic Leveling System
2011 Toyota RAV4 4WD/Remco pump
ReadyBrute Elite tow bar/Blue Ox baseplate


12th Man Fan

Flower Mound , Texas

Senior Member

Joined: 03/05/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 05/22/19 06:16pm Link  |  Quote  |  Print  |  Notify Moderator

How long has it been running? First thing it does is fill the water heater if it is not bypassed.


2014 GMC Duramax 4X4 DRW Crew

2015 DRV Tradition

pianotuna

Regina, SK, Canada

Senior Member

Joined: 12/18/2004

View Profile


Online
Posted: 05/22/19 06:40pm Link  |  Quote  |  Print  |  Notify Moderator

Hi,

Sounds like a torn membrane in the pump.

MrWizard

Traveling

Moderator

Joined: 06/27/2004

View Profile



Posted: 05/22/19 08:00pm Link  |  Quote  |  Print  |  Notify Moderator

CITY WATER FILL 'pump' bypass valve ??

our safari had that, had to be open to fill the water, and closed to use the pump

* This post was edited 05/22/19 08:18pm by MrWizard *


Radiate The Happy
....

Connected using Verizon and AT&T
1997 F53 Bounder 36s


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  General RVing Issues

 > Water pump
Search:   Advanced Search

Search only in General RVing Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS