RV.Net Open Roads Forum: Coleman Mach 8 AC - runs, no cold air

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Coleman Mach 8 AC - runs, no cold air

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
pconroy328

Colorado

Senior Member

Joined: 01/30/2015

View Profile


Offline
Posted: 06/12/19 10:11pm Link  |  Quote  |  Print  |  Notify Moderator

An update. Ordered a cap since it was a $30 fix and a logical starting place. My wife, bless her heart, watched a dozen Youtube videos and had it replaced by the time I got home.

I'm not sure she even knows what a capacitor does. [emoticon]
There's a YouTube video for everything.

Compressor is running.
We didn't test it for long, I'm a bit concerned that the air wasn't as cold as I recall.

But it was a cool night.
Tomorrow we'll fire it up again and see if we're out of the woods.
Or if a new upper unit is going to be required.

Thank you for all of your help!
Our fingers are crossed it was just the cap!

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > Coleman Mach 8 AC - runs, no cold air
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS