RV.Net Open Roads Forum: Tech Issues: New TV reception

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > New TV reception

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev
Sponsored By:
Lynnmor

Red Lion

Senior Member

Joined: 07/16/2011

View Profile



Good Sam RV Club Member


Posted: 09/11/19 06:46am Link  |  Quote  |  Print  |  Notify Moderator

lane hog wrote:



Yesterday I hooked up my 2005 era Winguard batwing antenna on the roof, but it wouldn't register anything until after I turned on the antenna gain boost (tiny power switch tucked away in my TV cabinet).



That tiny switch connects the antenna to the TV and also turns on power to the amplifier inside the antenna. In the off position, the TV is connected to the cable TV input.





Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev

Open Roads Forum  >  Tech Issues

 > New TV reception
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS