RV.Net Open Roads Forum: Progressive EMS is growling at me/Loud hummmm

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Progressive EMS is growling at me/Loud hummmm

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
danorske

Austin, Tejas

Full Member

Joined: 08/11/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 09/30/19 02:58pm Link  |  Quote  |  Print  |  Notify Moderator

I have had this EMS-HW50C from Progressive for about 10 years without any troubles. Now it is Growling/Humming loudly. everything appears to be working. no errors. maybe on its way out? any ideas. I guess I'll have to call them but thought I'd checking here first.
Ron


2008 Tuscany 4076, 40.6 ft. 3 Slides. Freightliner, Cummings ISC 360HP, Allison 3000MH. Now a Residential Fridge.
Toad = 2013 Ford F150, 4X4 off road.


cavie

Port Charlotte Fl/ Hindsdale MA

Senior Member

Joined: 04/28/2019

View Profile


Offline
Posted: 09/30/19 05:00pm Link  |  Quote  |  Print  |  Notify Moderator

SEND IT BACK. Should not make ANY kind of noise.


2011 Keystone Sprinter 323BHS. Retired Master Electrician. Retired Building Inspector.

All Motor Homes are RV's. All RV's are not Motor Homes.

suprz

rhode island

Senior Member

Joined: 01/04/2007

View Profile


Offline
Posted: 10/01/19 03:39am Link  |  Quote  |  Print  |  Notify Moderator

cavie wrote:

SEND IT BACK. Should not make ANY kind of noise.


Mine is less than a year old and it hums. Not too loud but it's noticeable if you listen for it. Google it and it's a common problem. Some do some don't. But they still work even if they hum and show no codes.

Now, at 10 years old... Cheaper ins to check into it, and maybe replace


Proud father of a US Marine


ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile


Offline
Posted: 10/01/19 10:24am Link  |  Quote  |  Print  |  Notify Moderator

I would check the connections and make sure all are still tight.
Mine is 2 y/o and quiet.


Scott, Grace and Wesly
2003 Dodge 3500 4x4, 6 speed Cummins.
2018 Silver Fox 32A.
H0NDA eu2000i

time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 10/01/19 11:15am Link  |  Quote  |  Print  |  Notify Moderator

Please post what PI instructs you to do.


2001 F150 SuperCrew
2006 Keystone Springdale 249FWBHLS
675w Solar pictures back up

10forty2

North Carolina

Senior Member

Joined: 07/08/2014

View Profile



Good Sam RV Club Member


Posted: 10/01/19 12:00pm Link  |  Quote  |  Print  |  Notify Moderator

My ATS hums slightly, but the Progressive EMS that I wired in makes no noise at all. I would suspect a loose connection first. Not meaning to doubt you, but are you sure its the EMS and not the ATS?


1999 Holiday Rambler Endeavor, 36' Gasser
Triton V10, Ford F53 Chassis
-----------------------------------------


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Progressive EMS is growling at me/Loud hummmm
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS