RV.Net Open Roads Forum: Class A Motorhomes: Electrical issue

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
pamo

branson missouri

New Member

Joined: 09/15/2019

View Profile



Posted: 10/09/19 01:30pm Link  |  Quote  |  Print  |  Notify Moderator

Have 2006 Fleetwood excursion. First trip and everything seemed to be working ok. Now the right side and front tv and bedroom tv have now power. Seems like circuits are not working. Checked breakers and all seemed to be good. Any ideas?

navigator2346

texas

Full Member

Joined: 03/29/2019

View Profile


Offline
Posted: 10/09/19 01:42pm Link  |  Quote  |  Print  |  Notify Moderator

Check for a tripped GFI and check for a tripped breaker on the inverter

Big Katuna

Deland, FL

Senior Member

Joined: 12/27/2003

View Profile



Good Sam RV Club Member

Offline
Posted: 10/09/19 01:43pm Link  |  Quote  |  Print  |  Notify Moderator

Check the breakers on the inverter.

Check the GFI on that side.


My Kharma ran over my Dogma.

2chiefsRus

USA Somewhere

Senior Member

Joined: 09/08/2004

View Profile





Offline
Posted: 10/09/19 04:04pm Link  |  Quote  |  Print  |  Notify Moderator

check gfi in bathroom and kitchen and maybe under table


Dave & Kathy
2007 Monaco Knight 40PDQ towing 2018 Ford F-150 & 2017 Harley Trike
Fulltime since October 2007
Before you give someone a piece of your mind, make sure you can get by with what will be left.
Our Blog
National Parks Visited

craig7h

Branson MO area

Senior Member

Joined: 03/23/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 10/10/19 03:34am Link  |  Quote  |  Print  |  Notify Moderator

With everybody else it sounds like a bad or tripped GFI outlet. Let us know what you find.


Itasca Meridian SE 36g
Road Master Tow Dolly

mrmichael80

Florida

New Member

Joined: 03/18/2015

View Profile



Good Sam RV Club Member

Offline
Posted: 10/10/19 04:49am Link  |  Quote  |  Print  |  Notify Moderator

FYI. Tvs will usually not be on if engine is running

eHoefler

ozark mountains

Senior Member

Joined: 10/22/2011

View Profile


Offline
Posted: 10/10/19 06:00am Link  |  Quote  |  Print  |  Notify Moderator

Try it on the generator, you could have a leg down on the 50 amp at the pedestal.


2019 Ram Limited, 3500, Crew Cab, 1000FTPD of Torgue!, Max Tow, Long bed, 4 x 4, Dually,
2006 40' Landmark Mt. Rushmore

tinkerer

Wisconsin

Senior Member

Joined: 03/22/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 10/10/19 06:10am Link  |  Quote  |  Print  |  Notify Moderator

I vote for the breaker buttons on the inverter. I had the same issue with my 2007 Discovery and it took me while to figure it out.

janstey58

Glenwood, IA

Senior Member

Joined: 08/29/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 10/10/19 11:09am Link  |  Quote  |  Print  |  Notify Moderator

TV are on your inverter, so likely that is the issue if other breakers are ok.


Jeff and Kim
2015 Fleetwood Discovery 40E
Freightliner Chassis 380HP DP
2012 Ford Escape Limited Toad

Executive

California/Arizona/South Dakota

Senior Member

Joined: 02/07/2008

View Profile





Offline
Posted: 10/10/19 11:43am Link  |  Quote  |  Print  |  Notify Moderator

FYI the 'breakers' on the inverter are different than ones you find in your electrical panel. They are usually button breakers. These are very small and easily missed. Look for a button about 1/8" in diameter. Push it in and see if that works....Dennis


A Simple Act of Caring Creates an Endless Ripple
Dennis and Debi Ten Years Full Timing
Monaco Executive M-45PBQ Quad Slide
525HP Cummins ISM 6 Spd Allison
2014 Chevrolet Equinox LTZ W/ ReadyBrute
CLICK HERE TO VIEW OUR TRAVEL BLOG



Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS