RV.Net Open Roads Forum: Tech Issues: no hot water electric or LP

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > no hot water electric or LP

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
pa bell

ohio

New Member

Joined: 08/09/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 11/05/19 07:01pm Link  |  Quote  |  Print  |  Notify Moderator

The SW6D is a direct ignition water heater with no pilot light. Are there any symptoms when you try to light on Propane? Nothing when using LP

Is there a light illuminated on the power switch in the RV? Power switch does light.

If you turn on the water heater do you hear or smell any propane? NO

Do you hear the igniter clicking or sparking? NO

Do you have a digital multimeter to check for power at various places?
Yes, I will be working on it tomorrow.

Thanks

Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 11/06/19 10:04am Link  |  Quote  |  Print  |  Notify Moderator

You stated it was a 'DEL' model

'DEL' models use 12VDC to control both electric & propane functions

Need to verify that you have 12VDC to BOTH on/off switches.
From the on/off switch the 2 circuits are independent ....
120VAC is triggered by a DC Relay
12VDC is used for propane



[image]


Is it time for your medication or mine?


2007 DODGE 3500 QC SRW 5.9L CTD In-Bed 'quiet gen'
2007 HitchHiker II 32.5 UKTG 2000W Xantex Inverter
On the Road Debt Free April '07
Off the road still Debt Free Jan. '14

time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 11/06/19 10:08am Link  |  Quote  |  Print  |  Notify Moderator

pa bell wrote:

Suburban SW6DEL will not heat water with LP or electric. Stove and furnace work fine with LP. Not sure what to look for. Any ideas?
Did it ever work?
Do you have 13.2+ volts on the battery and in the 12v distribution center?
Any chance the WH was not filled before turning on?


2001 F150 SuperCrew
2006 Keystone Springdale 249FWBHLS
675w Solar pictures back up

pa bell

ohio

New Member

Joined: 08/09/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 11/06/19 11:48am Link  |  Quote  |  Print  |  Notify Moderator

Yes, it has been used for 5 winters in Florida. Last spring before we left the electric would get too hot and come out the pressure relief valve. The LP worked fine. I took the switches from the wall and see 12V passing through both LP and electric with a multimeter. I do not see 12 V at either t-stat. I cleaned out the LP tube and orifice.

The battery is at 12.8. I had the generator running to provide shore power.

I am running out of time since the RV in a storage lot and I am using water from fresh tank. Tomorrow night will be 16 degrees and I think I should drain that tank and winterize.

Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 11/06/19 02:57pm Link  |  Quote  |  Print  |  Notify Moderator

You have 12VDC at & thru the Switches

The AC side....
DC goes to the DC Relay in DC Junction (backside of water heater tank) which then triggers AC to the OEM on/off switch (in outside compartment) then to the Left set of t-stats to element
**If you have DC from Electric on/off switch then you should have DC at Relay in Junction Box

Propane side....
DC from On/Off Switch goes to Right set of t-stats to circuit board (backside of water heater). From circuit board to gas valve/spark electrode
**If you have DC coming from Propane on/off switch then you should have DC at High Temp T-stat RED wire

pa bell

ohio

New Member

Joined: 08/09/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 11/06/19 06:22pm Link  |  Quote  |  Print  |  Notify Moderator

Thank you Old-Biscuit. I will be doing this tomorrow afternoon.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > no hot water electric or LP
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS