RV.Net Open Roads Forum: Fifth-Wheels: Duo Therm 65900-001 sparking but not lighting?

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Fifth-Wheels

Open Roads Forum  >  Fifth-Wheels

 > Duo Therm 65900-001 sparking but not lighting?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
thetundrawolf

Arizona

New Member

Joined: 07/12/2013

View Profile


Offline
Posted: 01/09/20 06:49pm Link  |  Quote  |  Print  |  Notify Moderator

Hi, I have an older trailer with a Duo Therm 65900-001 furnace, it's getting propane fine, and 120v, when I connect the thermostat wires the fan comes on, and it sparks, I hear the solenoids in the propane valve click on, and I see it sparking in the glass window, but it never ignites. Any ideas on why it's not igniting?

laknox

Arizona

Senior Member

Joined: 01/06/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 01/09/20 08:15pm Link  |  Quote  |  Print  |  Notify Moderator

thetundrawolf wrote:

Hi, I have an older trailer with a Duo Therm 65900-001 furnace, it's getting propane fine, and 120v, when I connect the thermostat wires the fan comes on, and it sparks, I hear the solenoids in the propane valve click on, and I see it sparking in the glass window, but it never ignites. Any ideas on why it's not igniting?


Might be a bad sail switch.

Lyle


2002 GMC Sierra 2500 HD Duramax Crew Cab 4x4 6.5' Bed
Banks Bullet Tuner and Monster Exhaust
B&W Turnover Ball with 5th Wheel Companion
2017 KZ Durango 1500 D277RLT
1936 John Deere Model A
International Flying Farmers 62 Year Member

Roger10378

Goodrich, MI.

Senior Member

Joined: 05/29/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 01/10/20 06:32am Link  |  Quote  |  Print  |  Notify Moderator

Probably a spider web in the burner tube. You wouldn't hear the gas valve if the sail switch was not working.


2005 Cardinal 30TS
2007 Chevy 2500HD D/A

StirCrazy

Kamloops, BC, Canada

Senior Member

Joined: 07/16/2003

View Profile



Posted: 01/10/20 06:34am Link  |  Quote  |  Print  |  Notify Moderator

i had the same issue with my camperi just bought. a good air gun and 10 min of blowing out the combustion side, it now works perfectly.

Steve


2014 F350 6.7 Platinum
2016 Cougar 330RBK

Chris Bryant

Arden, North Carolina

Senior Member

Joined: 03/26/2003

View Profile



Posted: 01/10/20 07:48am Link  |  Quote  |  Print  |  Notify Moderator

That’s an old furnace, most likely needs cleaning. If it is sparking the sail and limit switches are good.


-- Chris Bryant

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Fifth-Wheels

 > Duo Therm 65900-001 sparking but not lighting?
Search:   Advanced Search

Search only in Fifth-Wheels


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.