RV.Net Open Roads Forum: Tech Issues: Sylvania Microwave Oven - SC-11100

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Sylvania Microwave Oven - SC-11100

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
pianotuna

Regina, SK, Canada

Senior Member

Joined: 12/18/2004

View Profile


Offline
Posted: 01/12/20 01:40pm Link  |  Quote  |  Print  |  Notify Moderator

Unplug it. Wait 5 minutes. Plug it back in.

If that doesn't solve it, go to a store for a replacement unit.


Regards, Don
My ride is a 28 foot Class C, 256 watts solar, 556 amp hours of AGM in two battery banks 12 volt batteries, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.

buddhawolf

New York

New Member

Joined: 12/23/2019

View Profile


Offline
Posted: 02/22/20 11:45am Link  |  Quote  |  Print  |  Notify Moderator

The first thing to try is a "hard reset". Unplug it from the power line for a few minutes, plug it back in, set the clock, then try again.

If it still doesn't work, it may be a bad door switch or door switch mount.

One quick check is to gently hold down on the door while you press Start (or Cook).


Refrigerator review

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Sylvania Microwave Oven - SC-11100
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.