RV.Net Open Roads Forum: Class A Motorhomes: slideouts not working

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > slideouts not working

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
jgraham429A

florida

New Member

Joined: 02/12/2020

View Profile


Offline
Posted: 02/12/20 11:08am Link  |  Quote  |  Print  |  Notify Moderator

I have a 2001 Damon Challenger equiped with a power gear slideout system for 2 slideouts. Both slideouts stopped working and looking at the manual they operate off of the coach batteries. I had to pull the batteries out, but assumed the slideouts would still work. Is the fact that the coach batteries are not hooked up the problem? any suggestions what to look for would be appreciated. I am connected to electricity

Yankee Clipper

Cairo, GA

Senior Member

Joined: 06/08/2006

View Profile



Good Sam RV Club Member

Offline
Posted: 02/12/20 11:13am Link  |  Quote  |  Print  |  Notify Moderator

For my system, the PowerGear motors require that the coach be level, the batteries have at least 12.4 volts, and the engine be operating. Also, check your battery storage switch of ON or USE.

HTH


Yankee Clipper
2014 Winnebago Sightseer 33C on Ford F53 6.8l V10
2014 Honda CRV 4 down toad/Roadmaster Falcon2 with EvenBrake
TireMinder TPMS, Duke the overgrown Boxer mascot/lousy watch dog
Rosey the minidachshund resident Princess-in-Chief

jgraham429A

florida

New Member

Joined: 02/12/2020

View Profile


Offline
Posted: 02/12/20 11:32am Link  |  Quote  |  Print  |  Notify Moderator

thanks Yankee Clipper. The RV is level, but there are physically no batteries. I checked the battery connect/disconnect switch and started the unit, but still no success

way2roll

Wilmington NC

Senior Member

Joined: 10/05/2018

View Profile


Offline
Posted: 02/12/20 12:20pm Link  |  Quote  |  Print  |  Notify Moderator

jgraham429A wrote:

thanks Yankee Clipper. The RV is level, but there are physically no batteries. I checked the battery connect/disconnect switch and started the unit, but still no success


Mystery solved. No coach batteries, no power to the slides.

jdc1

Riverside, Ca

Full Member

Joined: 05/30/2011

View Profile


Offline
Posted: 02/12/20 02:43pm Link  |  Quote  |  Print  |  Notify Moderator

way2roll wrote:

jgraham429A wrote:

thanks Yankee Clipper. The RV is level, but there are physically no batteries. I checked the battery connect/disconnect switch and started the unit, but still no success


Mystery solved. No coach batteries, no power to the slides.


Yep...it completes the curcuit. Even a dead battery would make it work

ppine

Northern Nevada

Senior Member

Joined: 07/04/2016

View Profile


Offline
Posted: 02/12/20 05:58pm Link  |  Quote  |  Print  |  Notify Moderator

Even a partially charged battery may not work. Power up your rig and the slideouts should work.

Sam Spade

North Central Florida

Senior Member

Joined: 11/05/2015

View Profile


Offline
Posted: 02/13/20 06:00am Link  |  Quote  |  Print  |  Notify Moderator

jgraham429A wrote:

I had to pull the batteries out, but assumed the slideouts would still work. Is the fact that the coach batteries are not hooked up the problem?


What ?? Where do you think the power would come from with no batteries present ?
BAD assumption.
Yes, that is your problem.

NOTE: With my Damon, the slides are locked out when the engine is running.....meaning they won't move on purpose.


'07 Damon Outlaw 3611
CanAm Spyder in the "trunk"

jgraham429A

florida

New Member

Joined: 02/12/2020

View Profile


Offline
Posted: 02/13/20 06:53am Link  |  Quote  |  Print  |  Notify Moderator

you know my son told me just to take an old car battery and hook it up and probably completing the circuit would make it work. thanks everybody for your help.

Sam Spade

North Central Florida

Senior Member

Joined: 11/05/2015

View Profile


Offline
Posted: 02/13/20 01:34pm Link  |  Quote  |  Print  |  Notify Moderator

jgraham429A wrote:

you know my son told me just to take an old car battery and hook it up and probably completing the circuit would make it work. thanks everybody for your help.


Well THAT is bad advice too.

YOu need a healthy supply of 12 VDC to open the slides.
The only 2 ways you can get that is with a healthy battery OR if you are plugged into shore power.

Note the previous comment about the slides being disabled while the engine is running.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > slideouts not working
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.