RV.Net Open Roads Forum: Tech Issues: Water heater

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Water heater

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
ken56

Tennessee

Senior Member

Joined: 01/12/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 08/01/20 02:58pm Link  |  Quote  |  Print  |  Notify Moderator

OK, we were out in the trailer cleaning after a trip and forgot to turn the gas off for the heater. Propane ran out and don't know if the ignitor tried to keep things going so now I find out today I have no ignitor so now it won't light. Electric side works fine. Any ideas? Did I kill the board? Did I kill the ignitor? I tried pushing the reset buttons too and no movement on them. Its a Suburban gallon.

MitchF150

Puyallup, WA

Senior Member

Joined: 07/13/2002

View Profile


Offline
Posted: 08/01/20 03:22pm Link  |  Quote  |  Print  |  Notify Moderator

As long as there was water in the tank, I don't think there would have been any problem?

If the pilot blew out during travel, the igniter would have just tried to light after about a dozen tries and then the solenoid should have shut off the gas and then you should see a check light for the WH.

The gas 'should' not have kept flowing with no flame... If it did, then you have more problems with the system..

Since gas does not seem to work now, I can't really say? There are a fuse or 2 in the WH compartment itself?

Dunno... But, good luck with it! Mitch


2013 F150 XLT 4x4 SuperCab Max Tow Egoboost 3.73 gears #7700 GVWR #1920 payload. 2019 Rockwood Mini Lite 2511S.

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 08/01/20 03:29pm Link  |  Quote  |  Print  |  Notify Moderator

When the WH ran the LP empty, the Ignitor tried for 3 attempts and then shut OFF. You did not destroy the Circuit board by running out of LP. Did the WH have water in its tank when it stayed running? Doug

wa8yxm

Wherever I happen to park

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 08/01/20 04:00pm Link  |  Quote  |  Print  |  Notify Moderator

If you run out of gas it will try to relight (Assuming it runs out when lit) and if it fails it will try again, and if it fails it will try again, then it will shut down, lock out and fire up ye old FAULT (or Check) light.

Turn off. count to 1 turn back on. Should be good to heat. (NO guarantees)
In some cases. especially trailers you may get some air in the line. if this happens the heater should Try, fail, Try and succeed but if the lines are long and big enough there is a possibility it may go into fault one time.

Finally when you open the tank valve after refilling. Opening too fast can cause a safety device to engage and limit gas flow below the heater's need.


Home is where I park it.
Kenwood TS-2000 housed in a 2005 Damon Intruder 377


ken56

Tennessee

Senior Member

Joined: 01/12/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 08/01/20 06:19pm Link  |  Quote  |  Print  |  Notify Moderator

Everything is OK. Fiddled with the connections to make sure no corrosion and disconnected the LP tanks, reconnected LP tanks and flipped the switch and it lit off.

* This post was edited 08/01/20 06:27pm by ken56 *

wa8yxm

Wherever I happen to park

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 08/02/20 05:39am Link  |  Quote  |  Print  |  Notify Moderator

Modern LP thanks have an Excess Flow Feature. LIkely when you first reconnected the tanks you opened the valves too fast and tripped it.
Open till you hear gas flow pause and continue from there SLOWLY after 1 minute till full open works best.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Water heater
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.