RV.Net Open Roads Forum: Tech Issues: 7.5 Onan Diesel Generator

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > 7.5 Onan Diesel Generator

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
2000 American Eagle

Utah

New Member

Joined: 08/01/2020

View Profile



Good Sam RV Club Member

Offline
Posted: 08/01/20 09:25pm Link  |  Quote  |  Print  |  Notify Moderator

My Onan Generator is currently shutting down after running for a short time. I have had problems with this generator in our 2000 American Eagle since we purchased it in 2017. I had 210 hrs when we purchased it in 2017 and now 325 hrs. I had a very qualified technician check it out and replaced the control panel in 2017. I turn it on several times a year, load it up and it has been working most of the time. It seems to shut down when I need it. The code was 33 coolant high temp. I have changed thermostat, radiator cap, sensor, fuel filter, air filter. it is still shutting down with code 1 high temp. Any suggestions?

bobsallyh

Livingston, TX.

Senior Member

Joined: 01/08/2004

View Profile



Posted: 08/02/20 10:42am Link  |  Quote  |  Print  |  Notify Moderator

2000 American Eagle, can't help with the diesel Onan, we have a gas POS. Onan's are like an old woman, lot's of TLC!

Flute Man

Payson, Arizona

Senior Member

Joined: 03/21/2019

View Profile


Offline
Posted: 08/02/20 09:41pm Link  |  Quote  |  Print  |  Notify Moderator

How about the radiator or the fan? Does it overheat on no load?


Jerry Parr
05 Mandalay 40B
Cat C7 350
04 Honda CR-V
Ham Radio K7OU
Retired EE
Jrparr32@gmail.com
602-321-8141
Full-timer

Cloud Dancer

San Antonio and Livingston TX USA

Senior Member

Joined: 06/08/2001

View Profile



Posted: 08/02/20 09:58pm Link  |  Quote  |  Print  |  Notify Moderator

It could very well be mineral deposits inside the cooling tubes of the radiator. That's what it was on mine (same model of generator on my 2003 Dutch Star). I removed the radiator and took it to a radiator shop for a complete cleaning procedure. The problem never came back.


Willie & Betty Sue
Miko & Sparky
2003 41 ft Dutch Star Diesel Pusher/Spartan
Floorplan 4010
Blazer toad & Ranger bassboat

hypoxia

Arizona

Senior Member

Joined: 04/29/2003

View Profile



Good Sam RV Club Member

Offline
Posted: 08/03/20 05:01am Link  |  Quote  |  Print  |  Notify Moderator

Have you pulled the coolant fill hose with the radiator cap out and extended it above the top of the generator and topped off the coolant?


Jim

2007 Monaco Signature Noble III ISX 600HP

Shot-N-Az

Just South of DC

Senior Member

Joined: 06/22/2007

View Profile


Offline
Posted: 08/03/20 06:42am Link  |  Quote  |  Print  |  Notify Moderator

https://www.youtube.com/watch?v=0LB5ZhvhXas&t=146s

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > 7.5 Onan Diesel Generator
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.