RV.Net Open Roads Forum: Fifth-Wheels: A.C. problem

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Fifth-Wheels

Open Roads Forum  >  Fifth-Wheels

 > A.C. problem

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
M.R.E.

MI, usa

Full Member

Joined: 09/06/2003

View Profile



Posted: 08/13/20 08:53am Link  |  Quote  |  Print  |  Notify Moderator

My son-in-law in Texas just bought his first RV, a '16 Crossroads ReZerve 5th wheel with 2 A.C.'s. The bedroom one works but the main one doesn't blow cold. Any ideas what he can do to correct this ?
All help would be appreciated.


toolmaker

smarty

new mexico

Senior Member

Joined: 04/23/2012

View Profile


Offline
Posted: 08/13/20 09:31am Link  |  Quote  |  Print  |  Notify Moderator

has he gone on the roof and taken the cover off and looked at the unit yet? Cooling fins could be all plugged up. They make cleaning kits for the fins. Would be a good first thing to check

CA Traveler

The Western States

Senior Member

Joined: 01/03/2004

View Profile


Offline
Posted: 08/13/20 10:08am Link  |  Quote  |  Print  |  Notify Moderator

Have him search this board and the many A/C posts. He needs to isolate like does the fan work, AC and DC (if so equipped to the unit), or thermostat circuit. CB tripped and so forth. Of course air blockage inside and outside can be a factor.

Did he check it before purchase?


2009 Holiday Rambler 42' Scepter with ISL 400 Cummins
750 Watts Solar Morningstar MPPT 60 Controller
2014 Grand Cherokee Overland

Bob


cougar28

Lowell,AR USA

Senior Member

Joined: 01/03/2003

View Profile


Offline
Posted: 08/13/20 11:29am Link  |  Quote  |  Print  |  Notify Moderator

If fan is running make sure the compressor is running.


2002 F-250 SD CC 7.3PSD Auto. XLT Short Bed 4X4 Off-Rd.Pkg.Highland Green,Westin Sportsman Grille Guard (Black) RBW Li'l Rocker Slider ,Prodigy Control Towing Jayco Eagle HT 30.5 MLOK,Handy 5er tailgate

valhalla360

No paticular place.

Senior Member

Joined: 08/19/2009

View Profile



Posted: 08/13/20 11:29am Link  |  Quote  |  Print  |  Notify Moderator

I assume "not blowing cold" implies the fan is blowing...so that means there is power to the unit.

Can he hear the compressor kick over? If not, he needs to check if there is power to the compressor. That would involve taking the top off and putting a multimeter on the wires to the compressor at various points between where the power comes into the aircon and where they go into the compressor...when the compressor tries to turn on.

Yes, check the fins both inside and outside that they are reasonably clean. Just picked up a rig this year and when I reached up inside, they were fuzzier than a stuffed animal. Just take some water and a stiff bristle brush and scrub lightly with the direction of the fins and most of it should come right off (it can be a little messy so putting a piece of plastic on the floor inside isn't a bad idea). That made a huge difference in the cold output.

After that, you are probably looking at theromostats and control boards if you haven't found the problem.


Tammy & Mike
Ford F250 V10
2021 Gray Wolf
Gemini Catamaran 34'
Full Time spliting time between boat and 5er


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Fifth-Wheels

 > A.C. problem
Search:   Advanced Search

Search only in Fifth-Wheels


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.