RV.Net Open Roads Forum: Class A Motorhomes: What The Heck???

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev
Sponsored By:
way2roll

Wilmington NC

Senior Member

Joined: 10/05/2018

View Profile


Offline
Posted: 08/25/20 02:09pm Link  |  Quote  |  Print  |  Notify Moderator

jkc306 wrote:

Retracing my steps I identified errant house batt cable connection. disconnected this one cable from pos post to neg post. using only house batts, interior lights, slide-outs, awning etc working again. connected chassis battery no smoke, engine started. Shore power also working again. Seems i am now back to my original problem: LCI levelers will not retract. Did the reset at panel - that did not help; 15amp fuse in pump compartment ok. Here is a picture of the house batts [image] don't know that it will be useful...


Your positive posts seem to be connected but your negative posts still seem to be missing a cable to connect them.


2020 F350 STX 6.7L Turbo Diesel
2020 FR Cedar Ridge Silverback 29rw

rgatijnet1

Florida

Senior Member

Joined: 06/22/2009

View Profile



Good Sam RV Club Member


Posted: 08/25/20 02:17pm Link  |  Quote  |  Print  |  Notify Moderator

As long as the two negative posts both go to a common ground, they do not need to be connected together as the ground will connect them.
Going back to your ORIGINAL post, you said that you smelled an electrical odor from the house battery area. Usually when there is an odor, something is usually fried and is no longer working as designed. I would look for whatever burned and start from there. Check all fuses even if they look good. You can also apply 12 volt power to your jack pump and see if it operates. You have a few different interlocks that must be in the correct position before your jacks will operate. It might be time to go back to your manual and make sure that you are trying to retract them according to the book.

jkc306

95901

New Member

Joined: 07/26/2020

View Profile



Good Sam RV Club Member

Offline
Posted: 08/25/20 02:36pm Link  |  Quote  |  Print  |  Notify Moderator

WoW, like the saying goes KISS...The house battery cabling resolved. Everything works whether shore power or house batteries; chassis battery is good - engine starts right up. As for levelers turns out i tripped two buss fuses. Levelers operational, generator too! I continue to learn much from your advice - becoming a better RV'r. Now we have to reconfigure our road trip - Thank you everyone!


John Contreras

Executive

California/Arizona/South Dakota

Senior Member

Joined: 02/07/2008

View Profile





Offline
Posted: 08/25/20 02:47pm Link  |  Quote  |  Print  |  Notify Moderator

jkc306 wrote:

WoW, like the saying goes KISS...The house battery cabling resolved. Everything works whether shore power or house batteries; chassis battery is good - engine starts right up. As for levelers turns out i tripped two buss fuses. Levelers operational, generator too! I continue to learn much from your advice - becoming a better RV'r. Now we have to reconfigure our road trip - Thank you everyone!


Hurray! and it didn't cost you much...just some grey hairs... [emoticon] Oh! and a red spot where you slapped your forehead......Dennis


A Simple Act of Caring Creates an Endless Ripple
Dennis and Debi Eleven Years Full Timing
Monaco Executive M-45PBQ Quad Slide
525HP Cummins ISM 6 Spd Allison
2014 Chevrolet Equinox LTZ W/ ReadyBrute
CLICK HERE TO VIEW OUR TRAVEL BLOG



rgatijnet1

Florida

Senior Member

Joined: 06/22/2009

View Profile



Good Sam RV Club Member


Posted: 08/25/20 02:47pm Link  |  Quote  |  Print  |  Notify Moderator

Now go out and enjoy yourself. Glad things got resolved.

jorbill2or

Full time

Senior Member

Joined: 10/02/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 08/25/20 03:01pm Link  |  Quote  |  Print  |  Notify Moderator

Perfect .. save what you can of your trip and go. I hate electrical problems but you had a good outcome with little out of pocket it sounds .. Thanks for the update


Bill

way2roll

Wilmington NC

Senior Member

Joined: 10/05/2018

View Profile


Offline
Posted: 08/25/20 03:06pm Link  |  Quote  |  Print  |  Notify Moderator

jkc306 wrote:

WoW, like the saying goes KISS...The house battery cabling resolved. Everything works whether shore power or house batteries; chassis battery is good - engine starts right up. As for levelers turns out i tripped two buss fuses. Levelers operational, generator too! I continue to learn much from your advice - becoming a better RV'r. Now we have to reconfigure our road trip - Thank you everyone!


Awesome!!

oldave

Tx

Full Member

Joined: 06/19/2018

View Profile



Good Sam RV Club Member

Offline
Posted: 08/26/20 06:59am Link  |  Quote  |  Print  |  Notify Moderator

Great news

We all learn this way

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev

Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.