RV.Net Open Roads Forum: Class A Motorhomes: Dimension Inverter/Charger not charging batteries

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Dimension Inverter/Charger not charging batteries

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
dvleemin

Edmonton, Canada

Full Member

Joined: 11/19/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 08/27/20 10:46am Link  |  Quote  |  Print  |  Notify Moderator

Hi,
I was hoping someone had some ideas on how to resolve an issue I have with my Dimension Inverter/Charger not charging batteries.

Here are the details on the unit:
- 2005 Itasca Horizon 40AD
- Dimension 12x20B3RT Inverter/Charger

Problem:
- when plugged into shore power the batteries are not being charged.
- on the control panel it says: "CHGR-OFF NO INPT" AND "INVERTER-OFF
- the house and coach battery voltage is around 12.7 and shows that it is not charging
- The control unit does show that its on 30 amp
- 120V is available throughout the unit
- running the generator and not connected to short power results in the exact same result
- all fuses on the Dimension, on the chassis, and on the house seem fine

I was able to find the manual for the Dimension but not a lot of help: https://www.rvtechlibrary.com/electrical/dimensions_owners.pdf

I'm guessing some sort of transfer switch type of issue?

Anyone have any ideas on next steps to trouble shoot it?

Thanks,

Darryl

Executive

California/Arizona/South Dakota

Senior Member

Joined: 02/07/2008

View Profile





Offline
Posted: 08/27/20 11:09am Link  |  Quote  |  Print  |  Notify Moderator

Try pushing the on/off button three times and see if the inverter turns itself back on. Also check the internal fuse in the unit itself...Dennis


A Simple Act of Caring Creates an Endless Ripple
Dennis and Debi Eleven Years Full Timing
Monaco Executive M-45PBQ Quad Slide
525HP Cummins ISM 6 Spd Allison
2014 Chevrolet Equinox LTZ W/ ReadyBrute
CLICK HERE TO VIEW OUR TRAVEL BLOG



ndrorder

Southwest

Full Member

Joined: 05/09/2017

View Profile



Good Sam RV Club Member

Offline
Posted: 08/27/20 11:16am Link  |  Quote  |  Print  |  Notify Moderator

Here are three things to check.

1. None of the circuit breakers in the main panel at the foot of the bed are tripped.

2. None of the circuit breakers integral to the inverter/charger are tripped.

3. Verify 120V input power to the inverter/charger with a digital voltmeter.

Since you mentioned searching for manuals, I found the Itasca manual at the following link.

http://www.winnebagoind.com/resources/manuals/operatormanuals2005.php


__________________________________________________
Cliff
2011 Four Winds Chateau 23U

CA Traveler

The Western States

Senior Member

Joined: 01/03/2004

View Profile


Offline
Posted: 08/27/20 12:17pm Link  |  Quote  |  Print  |  Notify Moderator

Since the message indicates no AC input, what voltage do you read at it's input terminals? If you have done the above and don't know how to safely check then get help.


2009 Holiday Rambler 42' Scepter with ISL 400 Cummins
750 Watts Solar Morningstar MPPT 60 Controller
2014 Grand Cherokee Overland

Bob


dvleemin

Edmonton, Canada

Full Member

Joined: 11/19/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 08/27/20 01:24pm Link  |  Quote  |  Print  |  Notify Moderator

Executive wrote:

Try pushing the on/off button three times and see if the inverter turns itself back on. Also check the internal fuse in the unit itself...Dennis


Hitting the reset three times did nothing (didn't change anything on the display either oddly enough).

Confirmed the main fuse is fine.

dvleemin

Edmonton, Canada

Full Member

Joined: 11/19/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 08/27/20 01:25pm Link  |  Quote  |  Print  |  Notify Moderator

ndrorder wrote:

Here are three things to check.

1. None of the circuit breakers in the main panel at the foot of the bed are tripped.

2. None of the circuit breakers integral to the inverter/charger are tripped.

3. Verify 120V input power to the inverter/charger with a digital voltmeter.

Since you mentioned searching for manuals, I found the Itasca manual at the following link.

http://www.winnebagoind.com/resources/manuals/operatormanuals2005.php


Checked all these . . . 120V does even end up at the plugs in the RV.

dvleemin

Edmonton, Canada

Full Member

Joined: 11/19/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 08/27/20 01:25pm Link  |  Quote  |  Print  |  Notify Moderator

CA Traveler wrote:

Since the message indicates no AC input, what voltage do you read at it's input terminals? If you have done the above and don't know how to safely check then get help.


Input voltage is right around 120V . . .

time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 08/27/20 02:14pm Link  |  Quote  |  Print  |  Notify Moderator

Could try a full reboot by removing 120v power and disconnecting the battery connection for a few minutes.

My guess, the inverter is shot.


2001 F150 SuperCrew
2006 Keystone Springdale 249FWBHLS
675w Solar pictures back up

Lwiddis

Camping near Pearsonville, CA

Senior Member

Joined: 08/12/2016

View Profile



Good Sam RV Club Member

Offline
Posted: 08/27/20 06:11pm Link  |  Quote  |  Print  |  Notify Moderator

2005 converter needs replacement. You’ve been on borrowed time.


Winnebago 2101DS TT & 2020 Chevy Silverado 1500 LTZ Z71, 300 watts solar-parallel & MPPT, Trojan T-125s. TALL pole for flags. Prefer USFS, COE, BLM, NPS, TVA, USF&WS, state & county camps. Bicyclist! 14 year Army vet - 11B40 then 11A - (MOS 1542 & 1560)


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Dimension Inverter/Charger not charging batteries
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.