RV.Net Open Roads Forum: Class A Motorhomes: Air brake issue

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > Air brake issue

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
Todd20

Maryland

New Member

Joined: 10/17/2020

View Profile


Offline
Posted: 10/17/20 09:35am Link  |  Quote  |  Print  |  Notify Moderator

We have a 2011 discovery on Spartan Chassis, the air brakes release but show brake still engaged and warning appears when put in gear. wondering if anyone has had this issue and shed some guidance ?

FormerBoater

South Florida

Senior Member

Joined: 02/08/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 10/17/20 05:35pm Link  |  Quote  |  Print  |  Notify Moderator

Bad sensor...call Spartan for location. On my vintage Eagle it was actually connected to the parking brake valve itself.


Dave
1998 American Eagle 40EVS

FormerBoater

South Florida

Senior Member

Joined: 02/08/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 10/17/20 05:46pm Link  |  Quote  |  Print  |  Notify Moderator

Spartan can also give you the sensor part number.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  All

 > Air brake issue
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.