RV.Net Open Roads Forum: Class C Motorhomes: Installed new charger, batteries not charging

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class C Motorhomes

Open Roads Forum  >  Class C Motorhomes  >  All

 > Installed new charger, batteries not charging

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
SenroninTonomas

Toledo

New Member

Joined: 11/16/2020

View Profile


Offline
Posted: 11/16/20 10:20pm Link  |  Quote  |  Print  |  Notify Moderator

Hi all, I am new to the forum, I have a 1998 Winnebago and recently the battery charger stopped working, I figured I’ll just replace the converter/charger. So I did. Batteries still aren’t charging and also with the battery switch turned to off, shore power is not running the 12 volt system which was also occurring before I installed the new charger. Although the issue with shore power not being converted to 12volt with the battery switch off started happening more and more frequently this year. NOW the extremely weird part happening here is that before I installed the new converter and after...my Onboard generator (which I just plug my main 30amp power cable into) powers the 12 volt system with the battery switch off and with the battery switch on seems to charge the batteries(slowly).

So far I have
-checked my battery connections.
-checked all my power cables
-installed new power dynamics converter/charger
-installed new fuse panel
-Installed new male plug end on shore power cable
-Change the fuses in the little momentary battery switch in the battery bay
- check fuses and breakers

Summary —-
When plugged into shore power(30amp) my batteries are not charging and my converter is not running the 12 volt system with the battery switch off ...but the generator does both of these before and after installing new PD charger/converter

My thoughts
Idk...please help
I thought about replacing the 120 breaker but why would it work with the generator on and not shore power ?
PS I don’t have a generator shore power switch box, my shore power cable just plugs into the 30 amp outlet on the genset

cavie

Port Charlotte Fl/ Hindsdale MA

Senior Member

Joined: 04/28/2019

View Profile


Offline
Posted: 11/17/20 03:44am Link  |  Quote  |  Print  |  Notify Moderator

There are 2 reverse polarity fuses in the converter for the battery. There is an inline resettable fuse within 6' of the battery. The battery disconnect switch must be "IN-use".

Stop replacing parts. Buy a multimeter and learn how to use it. YouTube is your friend.

You can not fix electricity without a multimeter.


2011 Keystone Sprinter 323BHS. Retired Master Electrician. Retired Building Inspector.

All Motor Homes are RV's. All RV's are not Motor Homes.

bobndot

USA

Senior Member

Joined: 08/21/2007

View Profile


Offline
Posted: 11/17/20 06:19am Link  |  Quote  |  Print  |  Notify Moderator

I agree check breaker with meter. Here is a link with related info .

converter not charging battery

https://www.rvingknowhow.com/how-to-tell-if-rv-converter-is-bad/

time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 11/17/20 08:43am Link  |  Quote  |  Print  |  Notify Moderator

Get out your multimeter and measure the voltage of the converter output. Post the results.


2001 F150 SuperCrew
2006 Keystone Springdale 249FWBHLS
675w Solar pictures back up

SenroninTonomas

Toledo

New Member

Joined: 11/16/2020

View Profile


Offline
Posted: 11/17/20 03:12pm Link  |  Quote  |  Print  |  Notify Moderator

Good news, I finally got off my lazy but and checked everything with a multimeter and all the numbers checkout out and the batteries did charge over night and the converter is now working.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class C Motorhomes  >  All

 > Installed new charger, batteries not charging
Search:   Advanced Search

Search only in Class C Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.