RV.Net Open Roads Forum: Class A Motorhomes: Start

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
farmingdad

ky

Full Member

Joined: 10/28/2010

View Profile


Offline
Posted: 02/18/21 10:03am Link  |  Quote  |  Print  |  Notify Moderator

My friend got a 08 signature keeps burning up the little seloiniond in back run box after it started a couple of times. Then after awhile it burns the big boy up

MountainAir05

New Mexico

Senior Member

Joined: 01/27/2007

View Profile


Offline
Posted: 02/19/21 08:44am Link  |  Quote  |  Print  |  Notify Moderator

Without any info , either the wrong parts installed as too low in amps or they have one heck of a amp draw.

Groover

Pulaski, TN

Senior Member

Joined: 10/17/2007

View Profile


Offline
Posted: 02/19/21 11:00am Link  |  Quote  |  Print  |  Notify Moderator

We have already had a 3 page discussion on this but didn't get far due to a lack of information from you. Without some detailed info possibly including some pictures don't expect this thread to be any more productive than the last one.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.