RV.Net Open Roads Forum: Tech Issues: Ground wires

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Ground wires

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 03/21/21 08:00am Link  |  Quote  |  Print  |  Notify Moderator

Since this bothers you and I guess you want to tinker and make it better. I would take each white Ground wire, install a ring terminal, solder after crimping and drill a hole thru the frame and use star washers and secure a few wires to each new bolt stud. 15 wires, I would install 5 bolts and install 3 wire ring terminals on each new stud bolt. THEN undercoat each stud. never have to worry about looseness or corrosion. Doug

YES, That is how Jayco runs their 12 volt ground wires.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > Ground wires
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.