RV.Net Open Roads Forum: Truck Campers: One jack not functioning AF811

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Truck Campers

Open Roads Forum  >  Truck Campers

 > One jack not functioning AF811

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
thealexdexter

Lake Stevens, WA

Full Member

Joined: 05/07/2009

View Profile


Offline
Posted: 05/22/21 03:50pm Link  |  Quote  |  Print  |  Notify Moderator

I think it was changed last year. I’ll give it a go…


------------------------------------------------
2015 All Terrain GMC Sierra 4x4 CC Duramax
2016 Arctic Fox 811SB

thealexdexter

Lake Stevens, WA

Full Member

Joined: 05/07/2009

View Profile


Offline
Posted: 06/22/21 02:56pm Link  |  Quote  |  Print  |  Notify Moderator

I changed battery twice, checked all fuses again. Tried red and black remotes plugged into remote plug and directly to controller. Also made sure I was on the right mode and not trying to move the awning. I also tried another red remote direct wired. Nothing seems to work. I did get one jack to move once briefly.

I did notice that previously I would get the LED lights for each jack to come on red or green....even though nothing was moving. Now those LEDs do not ever come on.

Any last things to try before I blow $500 on a new controller?

mkirsch

Rochester, NY

Senior Member

Joined: 04/09/2004

View Profile



Posted: 06/23/21 06:41am Link  |  Quote  |  Print  |  Notify Moderator

Have you tried calling Reico Titan for advice yet?


Putting 10-ply tires on half ton trucks since aught-four.

thealexdexter

Lake Stevens, WA

Full Member

Joined: 05/07/2009

View Profile


Offline
Posted: 06/23/21 07:15am Link  |  Quote  |  Print  |  Notify Moderator

That is probably my next move, to call reico. I’m hoping it can be repaired cheaper than $500 for a new one.

brholt

Seattle

Senior Member

Joined: 11/17/2010

View Profile


Offline
Posted: 06/23/21 01:26pm Link  |  Quote  |  Print  |  Notify Moderator

Make sure it is not the button on the remote controller.

thealexdexter

Lake Stevens, WA

Full Member

Joined: 05/07/2009

View Profile


Offline
Posted: 08/05/21 01:53pm Link  |  Quote  |  Print  |  Notify Moderator

Finally resolved this. Sent controller back to Reico which was determined defective. $500 later it’s back working. Sure it’s 5 years old not basically it used. Should have lasted longer in my opinion.

Thank you to all for your suggestions on troubleshooting.

Highway Runner

Atlanta, Ga.

New Member

Joined: 05/16/2014

View Profile


Offline
Posted: 08/05/21 05:15pm Link  |  Quote  |  Print  |  Notify Moderator

I had to replace two of my jack motors last year. They quit working.
You can just take it off and plug it into a different location. It is a very easy process and will take about 30 minutes. Good luck!


2015 Eagle Cap 1165
2016 F-350 Lariat 4x4, 6.2 Boss Dually, 4.30 Axle
Air Lifter 7500 XL w Rancho 9000s & Torklift Stable Loads

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Truck Campers

 > One jack not functioning AF811
Search:   Advanced Search

Search only in Truck Campers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.