RV.Net Open Roads Forum: Chasing No left turn Signal on Trailer With Ram Truck

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tow Vehicles

Open Roads Forum  >  Tow Vehicles

 > Chasing No left turn Signal on Trailer With Ram Truck

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 09/14/21 07:23pm Link  |  Quote  |  Print  |  Notify Moderator

Me Again wrote:

SweetLou wrote:

enblethen wrote:

Check for a trailer connector fuse? Does the brake light work?
Looks like fuse 53
Fuse block

Brake lights work, I think. I need to check that again. Left signal works on truck so fuse 53 how could that be an issue if it works on the truck? Just asking


F53 = Trailer Tow – Left Turn/Stop Lights

Turned out a blown fuse. Didn't think about that until Enblethen mentioned it. Thanks guys for the help.


2013 3500 Cummins 6.7 Quadcab 4x4 3.73 68FE Trans, 2007 HitchHiker Discover America 329 RSB
We love our Westie


enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 09/14/21 09:36pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks for the update! Glad I could help. Did you save the owner's manual?


Bud
USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker


Groover

Pulaski, TN

Senior Member

Joined: 10/17/2007

View Profile


Offline
Posted: 09/15/21 06:26am Link  |  Quote  |  Print  |  Notify Moderator

Now you should check your utility trailer for a short circuit. Wiring on trailers is often done very poorly.

SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 09/15/21 06:38am Link  |  Quote  |  Print  |  Notify Moderator

enblethen wrote:

Thanks for the update! Glad I could help. Did you save the owner's manual?

I did! Great help. Thanks again!

SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 09/15/21 06:45am Link  |  Quote  |  Print  |  Notify Moderator

Groover wrote:

Now you should check your utility trailer for a short circuit. Wiring on trailers is often done very poorly.

Could only be two culprits. The Fifth Wheel, or my Cargo trailer. I think possibly the Fifth wheel. I was pulling it for a short one way trip when shortly on the drive and plugged into the bumper, the warning light came on saying trailer is disconnected. I pulled over and ended up switching the plug to the bed and it took care of it. May be there somewhere. Or my cargo trailer which has two sets of long LED lights on it and the upper left which is my problem side had 3-4 led lights burned out. Actually bought a replacement bank for it but never put it on. Now I'll check that side out first before replacing and doing damage to the new one.Thanks

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tow Vehicles

 > Chasing No left turn Signal on Trailer With Ram Truck
Search:   Advanced Search

Search only in Tow Vehicles


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.