RV.Net Open Roads Forum: Tech Issues: Generator only runs with engine on

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Generator only runs with engine on

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Sponsored By:
Rvpapa

Alberta , Can.

Senior Member

Joined: 08/07/2002

View Profile



Posted: 11/18/21 02:13pm Link  |  Quote  |  Print  |  Notify Moderator

Where does the generator get its fuel from?
Art

LittleBill

Scranton, PA USA

Senior Member

Joined: 08/29/2003

View Profile


Offline
Posted: 11/18/21 03:39pm Link  |  Quote  |  Print  |  Notify Moderator

sounds like the onan onboard fuel pump is dead. or if the definition of doesn't start means not crank. then on the board charging system is not working/powered and the batteries are going dead killing the fuel pump as well.

for those of you saying the onan has a charge circuit, it doesn't, at least not on the 4k onan.





Bobbo

Wherever I park

Senior Member

Joined: 09/16/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 11/18/21 08:39pm Link  |  Quote  |  Print  |  Notify Moderator

You folks need to read the entire thread.

OP says the ONAN will run as long as the chassis engine is running (providing 12v power to the fuel pump).

OP says the ONAN will run 5 to 15 minutes AFTER the chassis engine is shut off. That means the fuel already pumped up to the ONAN is being used up, but no additional fuel is being pumped (fuel pump is not running).

The upstart of this is that the fuel pump gets 12v power when, and ONLY when, the chassis engine is running. ERGO, no power to it from the batteries. Either the batteries are dead, the disconnect switch has them disconnected, or there is a blown fuse or break in the circuit between the batteries and the fuel pump.

(The ONAN doesn't have an alternator or generator because it depends on the batteries for its 12v power, knowing that the converter/charger is keeping the batteries charged.)


Bobbo and Lin
2017 F-150 XLT 4x4 SuperCab w/Max Tow Package 3.5l EcoBoost V6
2017 Airstream Flying Cloud 23FB


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > Generator only runs with engine on
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.